Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Mehdi_M_1
Beginner
51 Views

cluster_sparse_solver and cluster_sparse_solver_64

Hello all,

I have developed a code for 3D fluid flow using FEM coupeled method. Once I have used cluster_sparse_solver. For compiling this file I have used the following terms, using intel link advisor:

mpiifort USEFULLS.f90 CONSTANTS.f90 PRE_PROCESSOR_3D.f90 DATATYPES.f90 VEL_SUBS.f90 SPARSE_SUB.f90  parallel00.f90 -I"%MKLROOT%"\include  -heap-arrays mkl_intel_lp64_dll.lib mkl_intel_thread_dll.lib mkl_core_dll.lib mkl_blacs_lp64_dll.lib impi.lib libiomp5md.lib -o t1

When I increase the mesh number, the nonzero components of the A matrix (Ax = RHS) will exceed 500000000. So, based on the advide of the online document of the intel, I use cluster_sparse_solver_64. This time all of the integer input parameters are integer(8). in order to compile I do the following (again based on the link advisor):

mpiifort USEFULLS.f90 CONSTANTS.f90 PRE_PROCESSOR_3D.f90 DATATYPES.f90 VEL_SUBS.f90 SPARSE_SUB.f90  parallel01.f90  /4I8 -I"%MKLROOT%"\include  mkl_intel_ilp64.lib mkl_intel_thread.lib mkl_core.lib mkl_blacs_intelmpi_ilp64.lib impi.lib libiomp5md.lib  -o t1

But, I see the following error:

parallel01.f90(281): error #6285: There is no matching specific subroutine for this generic subroutine call.   [CLUSTER_SPARSE_SOLVER_64]

Can someone please help me. I had similar problem with pardiso and pardiso_64. But, in that case I add -i8 to the compiling term and the problem was solved. But, for cluster_sparse_solver, it seems to be more complicated.

Best regards

Mehdi

 

 

 

0 Kudos
1 Reply
Jing_X_Intel
Employee
51 Views

It seems that you called the wrong function. I suggest that you upload your source code or file a ticket in online-service-center.

The following two issues have the same error message as yours, please take as reference.

https://stackoverflow.com/questions/24287436/how-to-have-generic-subroutine-to-work-in-fortran-with-... parameter for the function call is incorrect.

https://software.intel.com/en-us/forums/intel-fortran-compiler-for-linux-and-mac-os-x/topic/271155: related to procedure declaration.

Reply