Community
cancel
Showing results for 
Search instead for 
Did you mean: 
zz
Beginner
141 Views

intelem not available as fcompiler

After install MKL 2015. I can only see "intelvem" is available. "intelem" is not available.

What I need to do if I want to use intelem as fcompiler?

 

 

IntelEM64VisualFCompiler instance properties:
  archiver        = ['C:\\Program Files (x86)\\Intel\\Composer XE
                    2015\\bin\\intel64\\ifort.exe', '/verbose', '/OUT:']
  compile_switch  = '/c '
  compiler_f77    = ['C:\\Program Files (x86)\\Intel\\Composer XE
                    2015\\bin\\intel64\\ifort.exe', '-FI', '-w90', '-w95',
                    '/nologo', '/MD', '/nbs', '/Qlowercase', '/us', '/O1',
                    '/QaxM']
  compiler_f90    = ['C:\\Program Files (x86)\\Intel\\Composer XE
                    2015\\bin\\intel64\\ifort.exe', '-FR', '/nologo', '/MD',
                    '/nbs', '/Qlowercase', '/us', '/O1', '/QaxM']
  compiler_fix    = ['C:\\Program Files (x86)\\Intel\\Composer XE
                    2015\\bin\\intel64\\ifort.exe', '-FI', '-4L72', '-w',
                    '/nologo', '/MD', '/nbs', '/Qlowercase', '/us', '/O1',
                    '/QaxM']
  libraries       = []
  library_dirs    = []
  linker_exe      = None
  linker_so       = ['C:\\Program Files (x86)\\Intel\\Composer XE
                    2015\\bin\\intel64\\ifort.exe', '-shared', '-shared']
  object_switch   = '/Fo'
  ranlib          = None
  version         = LooseVersion ('15.0.1.148')
  version_cmd     = ['C:\\Program Files (x86)\\Intel\\Composer XE
                    2015\\bin\\intel64\\ifort.exe', '/FI', '/c',
                    'c:\\users\\zhang005\\appdata\\local\\temp\\tmp9rp07o\\ask
                    smk.f', '/o',
                    'c:\\users\\zhang005\\appdata\\local\\temp\\tmp9rp07o\\ask
                    smk.o']
Fortran compilers found:
  --fcompiler=intelvem  Intel Visual Fortran Compiler for 64-bit apps
                        (15.0.1.148)
Compilers available for this platform, but not found:
  --fcompiler=absoft   Absoft Corp Fortran Compiler
  --fcompiler=compaqv  DIGITAL or Compaq Visual Fortran Compiler
  --fcompiler=g95      G95 Fortran Compiler
  --fcompiler=gnu      GNU Fortran 77 compiler
  --fcompiler=gnu95    GNU Fortran 95 compiler
  --fcompiler=intelem  Intel Fortran Compiler for 64-bit apps
  --fcompiler=intelev  Intel Visual Fortran Compiler for Itanium apps
  --fcompiler=intelv   Intel Visual Fortran Compiler for 32-bit apps
Compilers not available on this platform:
  --fcompiler=compaq   Compaq Fortran Compiler
  --fcompiler=hpux     HP Fortran 90 Compiler
  --fcompiler=ibm      IBM XL Fortran Compiler
  --fcompiler=intel    Intel Fortran Compiler for 32-bit apps
  --fcompiler=intele   Intel Fortran Compiler for Itanium apps
  --fcompiler=lahey    Lahey/Fujitsu Fortran 95 Compiler
  --fcompiler=mips     MIPSpro Fortran Compiler
  --fcompiler=nag      NAGWare Fortran 95 Compiler
  --fcompiler=none     Fake Fortran compiler
  --fcompiler=pathf95  PathScale Fortran Compiler
  --fcompiler=pg       Portland Group Fortran Compiler
  --fcompiler=sun      Sun or Forte Fortran 95 Compiler
  --fcompiler=vast     Pacific-Sierra Research Fortran 90 Compiler
For compiler details, run 'config_fc --verbose' setup command.
 

0 Kudos
2 Replies
TimP
Black Belt
141 Views

I don't think you've fully explained what you're up to, but you quote some options which have been replaced by new spellings in the current ifort, after years of warnings.  Your build logs would tell which options are rejected and must be updated.  The docs, including "ifort -help" tell you about the current replacements, e.g. for /us /nbs  => /assume:underscore,nobscc
 

141 Views

Zhen,

   When you installed Composer XE for Fortran ed or Parallel Studio XE for Fortan and if you have selected to install the 64 bit version too, you should be able to build 64 bit application.  Try setting the environment with ifortvars.bat intel64.

--Vipin

Reply