Community
cancel
Showing results for 
Search instead for 
Did you mean: 
HMads
Beginner
2,746 Views

Powershell module TLS not working

Hi All...

I'm having issues using powershell to communicate with my Intel AMT devices.

It's been working just fine before, but now i get a Schannel error 70 (protocol error)

I guess it's because of Intel AMT not supporting TLS 1.0 any longer.

How can i get the poweshell module to work again?

The AMT version on the client is 12.0.6 and FW is 12.0.6.1120

Please advice

/Heine

0 Kudos
11 Replies
idata
Community Manager
266 Views

Hello heinekmadsen,

 

 

I would like to inform that Intel SCS 12.0 has deprecated the TLS 1.0 security protocol for Intel® SCS communication with Intel® AMT, due to the fact The TLS 1.0 protocol has identified security vulnerabilities.

If you would like to know more information about it, I would like to refer you to the following PDF File in the section 3.13.

 

 

https://www.intel.com/content/dam/support/us/en/documents/software/Intel_SCS_User_Guide.pdf

 

 

Please if you have any other question, let me know and I will be more than happy to assist you.

 

 

Best regards,

Emeth O

HMads
Beginner
266 Views

Hi,

Did you even read my full post and viewed the screenshots?

Seems like you just repeated my own findings as i also state that TLS 1.0 is no longer supported.

My issue is getting the powershell module to work now thet TLS1.0 is depricated, and the module seems to default to TLS 1.0 (Correct me if i'm wrong)

What I need is a powershell module that's able to use TLS with the new version 12. The current module seems outdated.

/Heine

idata
Community Manager
266 Views

Hello,

Ok, please accept my apologize for the misunderstanding.

I am going to investigate more details about the information that you are looking for in order to provide you the most accurate answer about it.

Have a wonderful day.

Best regards,

Emeth O

idata
Community Manager
266 Views

Hello,

I was reviewing some details about this issue that you have been facing and I would like to let you know that the problem is that the powershell module supports TLS 1.0 and 1.0 only.The request will be to upgrade the powershell capability to support TLS 1.1 and 1.2. Unfortunately, this is not something that happens overnight.

 

 

However, let me ask you something:

Did you upgrade the system recently?

 

Did you were using an older system with an older AMT firmware?

 

Did you connect previously without TLS and just recently implemented TLS?

 

 

I will be waiting your outcome in order to proceed with the next step.

Best regards,

Emeth O

HMads
Beginner
266 Views

Hi..

Thanks for looking into this issue.

The situation is that we did a PoC in out test environment and the started to implement in production.

We decided to go with the latest versions in production because of the security improvements.

If the powershell module will be updated it would be great.

/Heine

Nader_T_Intel1
Employee
266 Views

Hello heinekmadsen,

I am following up this case, on behalf of my co-worker.

You will be contacted back as soon as we have an answer for you.

Have a great day.

Regards,

Nader T

Intel Customer Support Technician

Under Contract to Intel Corporation

idata
Community Manager
266 Views

Hello,

Could you please so kind and provide us the version of the powershell module that you are using?

Best regards,

 

Emeth O
HMads
Beginner
266 Views

Hi...

Sorry for the late answer...

We use the version 3.2.4 (according to the entry in Add/Remove programs in control panel)

/Heine

idata
Community Manager
266 Views

Hello,

 

 

Thank you so much for the information.

We are going to investigate more information about it because according to out last update TLS 1.0 will not be supported any more.

Let me ask to our upper level department in order to provide you the most accurate information.

 

 

Best regards,

Emeth O

idata
Community Manager
266 Views

Hello,

Thank you so much for your patience.

 

 

We are working with the developers to get the powershell module to support TLS 1.1 and 1.2. There is no timeframe at the moment as to when this will be implemented.

 

 

There is nothing we can do at the moment to make the PowerShell module work with AMT12 but the conversations for getting the tools updated is happening.

 

 

As per the engineering department this threat will be close and an upper level department will be contacting with you as soon as possible with the outcome of this.

 

Best regards,

Emeth O.

 

 

JusyD
Novice
266 Views

Hello iData,

 

"As per the engineering department this threat will be close and an upper level department will be contacting with you as soon as possible with the outcome of this. "

 

Has there been any additional info and progress on a new Powershell compatibility resolution with TLS1.2 support?

 

 

 

Reply