Media (Intel® Video Processing Library, Intel Media SDK)
Access community support with transcoding, decoding, and encoding in applications using media tools like Intel® oneAPI Video Processing Library and Intel® Media SDK
Announcements
The Intel Media SDK project is no longer active. For continued support and access to new features, Intel Media SDK users are encouraged to read the transition guide on upgrading from Intel® Media SDK to Intel® Video Processing Library (VPL), and to move to VPL as soon as possible.
For more information, see the VPL website.

can decoder handle noisy or skipped frames?

mahmut_şamil_s_
Beginner
326 Views

Hi,

I am trying to run decoder for the live streams. When i demux streams and isolate video stream, I just push it to Intel decoder. Under normal conditions, it Works well. However, decoder enter an unwanted state when i get an noisy or skipped frame from demuxer.

I tried to follow problem. In my case; when i get an abnormal packed frame from demuxer, Decoder generates  a noisy image. This is normal. But i espect that decoder can clean up this situation after any idr frame or key frame. In my trials, Intel decoder can not handle this abnormallity.

For testing, i generate a .bin file including H264 video frames.

I run sample code as below.

sample_decode.exe h264 -i demuxvideoout.bin -o test.yuv

 

 The sample packed video demuxvideoout.bin file can be downloaded from the adress:

https://www.wetransfer.com/downloads/4e4da0409efd95118b694f810a7b3a8c20151002171907/ebe92f070795c0fa686ebd6d8262408020151002171907/e3d7d7

 
 
In the test video, A noisy or skipped frames are injected to 855th frame. When output test.yuv file is analysed, i see that decoder start to genarates wrong frames again and again.
 
In each 192 frames, it generates 11 old frames unrelated to input. For example, in 1030. frame or in 1222. frame, it shows very very old frame.
 

Thank you for your helps

 
Mahmut

 

0 Kudos
4 Replies
Sravanthi_K_Intel
326 Views

Hi Mahmut, Thank you for your excellent post here and for sending us the input file as well. We will analyze the issue you are seeing and get back to you. To complete your setup information - can you let us know what version of Media Server Studio you are using, the platform you are on, the driver version? This information will be very useful for us.

Thanks.

0 Kudos
mahmut_şamil_s_
Beginner
326 Views

We are using 2015 R6 SDK. I observe same problem in both Software and Hardware driver.

 

Hardware we tested in is Intel Iris 6100  (NUC5i7RYH) driver version 10.18.15.4279.

 
 
 
 
 

 

0 Kudos
Sravanthi_K_Intel
326 Views

Thanks Mahmut, I am able to reproduce the issue as well - thanks for bringing it to our notice. I am following it up with my team here and will update you (via email). 

0 Kudos
Sravanthi_K_Intel
326 Views

Hi Mahmut, I have some update regarding the issue you observed. After consulting our media experts, we identified that to decode the encoded stream (which has error in it), the decoder will need to be non-conformant - which is not acceptable. Hope this helps. 

0 Kudos
Reply