Media (Intel® oneAPI Video Processing Library, Intel Media SDK)
Access community support with transcoding, decoding, and encoding in applications using media tools from Intel. This includes Intel® oneAPI Video Processing Library and Intel® Media SDK.
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.

decoding mpeg2 by Media SDK

kohshinToku
Novice
2,149 Views

Hello.

My name is Tokunaga.

I inquired problem of Media SDK through EXEL Soft.
It is decoding of mpeg2 by Media SDK.

I hear that the inquiry number is #04949055.

Is there anything I can do here?

Regards.

0 Kudos
20 Replies
AthiraM_Intel
Moderator
2,108 Views

Hi,


Thanks for reaching out to us.

We are checking on it internally, will get back to you soon.


Thanks.



Mark_L_Intel1
Moderator
2,096 Views

Hi Tokunaga San,

 

Yes, I have contact XLSoft for the MPEG2 to reproduce the issue.


Again, I am apologized for the late response. Dev team started investigate this issue recently and they want to get the MPEG2 file to reproduce the issue. Since it was a while ago, I remembered the issue was reproducible with the data file after modifying the original sample.

 

Mark

kohshinToku
Novice
2,062 Views

Hi Mark.

 

Should I do anything about this problem?

 

Tell me if you want my help.

 

Regards.

Mark_L_Intel1
Moderator
2,043 Views

Thanks so much Tokunaga San,

 

Dev team is asking if you can send us the MPEG2 file to reproduce the issue.

 

I got your reproducer file in January and I submitted it to dev team. They want to use the MPEG2 file to reproduce.

 

Mark

 

kohshinToku
Novice
2,023 Views

Hi Mark

 

I sent a file that was used.

 

It is elementary stream of mpeg2.

 

If you have any questions, please ask.

 

Regards.

Mark_L_Intel1
Moderator
2,007 Views

Hi Tokunaga San,


Thanks so much for the quick response, I have send this to dev team and I will keep you updated.


Mark


Mark_L_Intel1
Moderator
1,978 Views

Hi Tokunaga San,

 

I checked your video and didn't see the noise strip you mentioned in the original document, but I did find some glitch like noise at the fix position, is this the issue?

artifact.PNG

I found 2 places at output and I have to slow down the playback rate:

sample_decode mpeg2 -i elementary_stream.img -r -f 25.

 

It is very small and quick, I found this artifact at 2 times from the output.

 

Mark

 

kohshinToku
Novice
1,965 Views

Hi Mark

 

Thank you for replay.

 

I think your point is different from my problem.

 

My problem arises when I split the elementaly stream into smaller pieces and feed them to the Media SDK.

 

The reason for this small division is that in my system data is transmitted via UDP over the network.
Your point would be packet loss that occurred during reception.

The previously sent data will be sent again.

 

Regards.

 

Mark_L_Intel1
Moderator
1,962 Views

"I split the elementaly stream into smaller pieces and feed them to the Media SDK", I understand better now. Can you describe how to split and why we need to change the original source file accordingly?


The problem is, if we input the split data as many data file as the package, we are not using it in a regular way. I am not quite familiar with MPEG2, but if you split it, is it still a normal stream?


Mark


kohshinToku
Novice
1,923 Views

Hi Mark

 

We develop the decoder of monitoring system.

IP camera send the data through the local area network.

IP cameras send splited data to prevent fragmentation.

See

https://en.wikipedia.org/wiki/IP_fragmentation

about fragmentation.

 

The reason I changed Media SDK source, I tried to reproduce the phenomenon.

We couldn't reproduce the phenomenon at The long elementary stream.

 

I am attaching the packet data sent from the IP camera for your reference.

 

Regards.

 
kohshinToku
Novice
1,921 Views

if (pBS->DataLength == 1) {
memmove(pBS->Data, pBS->Data + pBS->DataOffset, pBS->DataLength); ------ break point
}
else {
memmove(pBS->Data, pBS->Data + pBS->DataOffset, pBS->DataLength);
}

 

I wanted to point that DataLength is 1 sometimes at splited data.

I checked it by setting break point.

Mark_L_Intel1
Moderator
1,913 Views

Hi Tokunaga San,


I can't validate from your answer if this modification changes Media SDK requirement or not.


My question was, if you want to supply the data files instead of MPEG2 stream, it must be satisfied with MPEG2 standard; in other words, the bitstream represented by these files must be a standard MPEG2 steam. If it is not, this would be out of the current Media SDK requirement, dev team can't trade it as a bug.


Mark


Mark_L_Intel1
Moderator
1,906 Views

Hi Tokunaga San,


Dev team sent me an update saying they have reproduced it based on your original package. I will keep you updated with any progress.


Mark


Mark_L_Intel1
Moderator
1,815 Views

Hi Tokunaga San,


Some update, dev team had identify the issue at the frame level and they found some clues on which code causes the problem, still waiting for the further analysis.


Mark


Mark_L_Intel1
Moderator
1,802 Views

Hi Tokunaga San,


Dev team has found the root cause: data_0027.bin end with 00 00 01 07, data_0300.bin end with 00 00 01 09, both are slice start-code, which indicates the 7th slice and 9th slice in the current frame. But MSDK lib skips these four bytes and then skip the related slice, cause the noise in the frame.


This was caused by the code merge by mistake. We will fix it in Media SDK library. But there might be a deployment issue since we only have one release a year, how urgent do you want this fix?


Mark


kohshinToku
Novice
1,654 Views

Hi Mark.

 

Sorry for the late reply.
I had Covid-19 and was in the hospital for 20 days. True story.

Thanks for the research on the issue.

- I hope to have it fixed as soon as possible as it is an important issue for my company.

- Could you please give me a test version of the product so I can see if the fix matches the problem I am having?

 

Regards.

 

Mark_L_Intel1
Moderator
1,607 Views

Wow! If you didn't tell me this is true story I would think this is a joke. This is the first time someone tell me he had it!

I heard this COVID-19 is not easy to recover so let me pray for your full recovery.


I had some good news for you, dev team told me they had a fix and they send me the package. I will try it first to see if it work, once confirmed, I will send you.


I have other tasks recently, so please allow me for 1 week.


Mark Liu


kohshinToku
Novice
1,371 Views

Hi Mark

 

Unfortunately my lungs seem to be a little damaged.
However, I am trying to recover to a level that is not a problem in my daily life.
Please be careful not to get this virus.

 

I am waiting for your fixed version.

 

Regards.

Mark_L_Intel1
Moderator
1,358 Views

Hi Tokunaga San,


Thanks for the reminder and apology for the delay.


Since this is a library fix and we are not in new release cycle, we will build a special package for you to check first. Let me get the package ready and send to you.


Mark


kohshinToku
Novice
517 Views

Hi Mark.

 

I updated graphics driver. And I could confirm to be fixed this problem.

 

Did you fix by driver's update after all?

 

So could you tell me the driver's number to be fixed?

 

ex) igfx_win_xxx.xxxx.exe

 

Regards.

Reply