Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Valued Contributor III
1,405 Views

Missing NIOS II Menu on Eclipse

Hello, 

I have some problems in Eclipse (NIOS II) because I need to generate the BSP (right click on BSP part of the project->NIOS II->Generate BSP) and that menu disappeared. I can not find it again. I could run some projects but every time I was deleting and creating another project to get an updated BSP. I found one thread ("Unable to regenerate BSP in Eclipse NIOS II EDS") that says to type a command on the console but I am not able to type on the console and if I could be, I would have to do it always manually :( The other option of that thread is reinstalling Eclipse. 

 

Does anyone know if there is any option to get the menu back without reinstalling everything?  

 

Thank you in advance.
0 Kudos
8 Replies
Highlighted
Valued Contributor III
4 Views

Re: Missing NIOS II Menu on Eclipse

I've the same problem. I is gone without any reasons. Second time already, have seen this also with 10.1 and at that time I switched over to 11 

I'm getting a little bit tired of the Altera tools... often the USB-blaster is not recognized and you have to click it many many times before it recognise and the programmer sometimes crashes when files are missing. 

The Eclipse environment does not show the NiosII menu anymore and also sometimes the Run As hardware disappears.... 

Very very frustrating
0 Kudos
Highlighted
Valued Contributor III
4 Views

Re: Missing NIOS II Menu on Eclipse

Sometimes that option desappears if I open the NIOS II from Quartus, but if I open it from the menu it works... I do not know, it is so weird. Right now it is working perfectly (I opened it from Quartus and it is ok) so no idea what is going on there. 

 

Anyway thanks for your answer and hope it to work for you too! :)
0 Kudos
Highlighted
Valued Contributor III
4 Views

Re: Missing NIOS II Menu on Eclipse

You can refer to this post for the missing perspective : http://www.alteraforum.com/forum/showthread.php?t=20785&page=2 

 

For the missing "Run as hardware", the nios II errata sheet indicates that it occurs only one time after the EDS installation and you only have to close and restart the app ... 

 

I also get a bit tired about Quartus II, there are too much issues with the last releases ...
0 Kudos
Highlighted
Valued Contributor III
4 Views

Re: Missing NIOS II Menu on Eclipse

The problem of disappearance of Nios II menu in Eclipse to edit and generate BSP (after you right-click on the BSP project) can be solved when you click on Window --> Open Perspective --> Other... --> Resource.

0 Kudos
Highlighted
Valued Contributor III
4 Views

Re: Missing NIOS II Menu on Eclipse

This now seems to be fixed (for me) in V12.0sp2.  

I think it may have been related to issues due ti the fact I had other Cygwin installations, and they were interacting. 

None of those problems now, with v12.0.sp2 

cheers, 

Beau Webber
0 Kudos
Highlighted
Beginner
4 Views

Re: Missing NIOS II Menu on Eclipse

Hello,

0 Kudos
Highlighted
Beginner
4 Views

Re: Missing NIOS II Menu on Eclipse

Hello,

0 Kudos
Highlighted
Beginner
4 Views

Re: Missing NIOS II Menu on Eclipse

I faced similar issue with Eclipse that comes with Quartus 17.1. Nios II option suddenly disappeared. Following helped to restore that option: In Eclipse, Windows -> Perspective -> Reset Perspective.

 

0 Kudos