Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Valued Contributor III
1,373 Views

Problem when downloading zImage to DE2-115

Hello altera forum, I have been currently working with DE2-115 using uClinux for over 4 months now, and all this time me and an student which is finishing his master degree, have been passing through some difficulties to run successfully the uClinux on this altera board, we have managed to get it working but there was always problem with the SD-Card. 

 

We have contacted some people that have posted their experiences on this problem and have received quite helpful feedback, but still the problem persists. 

 

The primary helpful person I have contacted is johan granath, he managed to get us his project files in order for us to get it working, I recompiled the project generating a .sof with Full License, so its not time limited, and it has successfully compiled, so no errors were supposed to appear, but after the: 

nios2-configure-sof "sof file" 

it works all sweet. 

but when we are downloading the zImage the mess appears: 

nios2-download -g zImage: 

Using cable "USB-Blaster ", device 1, instance 0x00 Pausing target processor: not responding. Resetting and trying again: FAILED Leaving target processor paused  

I have searched over the forum to an solution to this problem but none of the solutions seen were able to help me to fix this. 

 

I have attached the .sof file and zImage i'm using to see if there is a problem with then for you guys, or is something misconfigured here. 

 

the attached files belongs to johan granath, as was said before. 

 

Thanks in advance.
0 Kudos
8 Replies
Highlighted
Valued Contributor III
3 Views

I have the same problem as yours but just with one difference. I am not able to get it working without SD Card. However, the output of nios2-download command gives the same. If you find something to fix the problem, please don't forget to share it. 

 

By the way, here[1] jpe1313 nicknamed user said me that there was something wrong with .dts file but have no idea how to edit .dts file in order to get it working. 

 

Cem 

 

[1]: http://www.alteraforum.com/forum/showthread.php?t=17632
0 Kudos
Highlighted
Valued Contributor III
3 Views

This is jpe1313, 

What I was saying was that are any of your entries your generated *.dts file "unknown." Take a look. If they are "unknown" then it COULD be a problem. For my custom design my "timer" was undefined and I had to define it properly. As far as the SD card. To clarify, I am not using the SD card in my design. I have a daughter card that has a Compact Flash.  

 

Let me know if you need more help - but check your DTS
0 Kudos
Highlighted
Valued Contributor III
3 Views

 

--- Quote Start ---  

This is jpe1313, 

What I was saying was that are any of your entries your generated *.dts file "unknown." Take a look. If they are "unknown" then it COULD be a problem. For my custom design my "timer" was undefined and I had to define it properly. As far as the SD card. To clarify, I am not using the SD card in my design. I have a daughter card that has a Compact Flash.  

 

Let me know if you need more help - but check your DTS 

--- Quote End ---  

 

 

I was not able to post without administrator's approval. So i sent my message here. I maybe wrote 5-6 times but it seems all admins are sleeping. 

 

Anyway, i have no unknown parameters.  

 

/* 

* This devicetree is generated by sopc2dts on Fri Apr 19 16:30:38 EEST 2013 

* Sopc2dts is written by Walter Goossens <waltergoossens@home.nl

* in cooperation with the nios2 community <Nios2-dev@sopc.et.ntust.edu.tw

*/ 

/dts-v1/; 

 

/ { 

model = "ALTR,onur"; 

compatible = "ALTR,onur"; 

# address-cells = < 1 >; 

# size-cells = < 1 >; 

 

cpus { 

# address-cells = < 1 >; 

# size-cells = < 0 >; 

 

cpu: cpu@0x0 { 

device_type = "cpu"; 

compatible = "ALTR,nios2-12.1"; 

reg = < 0x00000000 >; 

interrupt-controller; 

# interrupt-cells = < 1 >; 

clock-frequency = < 50000000 >; /* embeddedsw.CMacro.CPU_FREQ type NUMBER */ 

dcache-line-size = < 32 >; /* embeddedsw.CMacro.DCACHE_LINE_SIZE type NUMBER */ 

icache-line-size = < 32 >; /* embeddedsw.CMacro.ICACHE_LINE_SIZE type NUMBER */ 

dcache-size = < 2048 >; /* embeddedsw.CMacro.DCACHE_SIZE type NUMBER */ 

icache-size = < 4096 >; /* embeddedsw.CMacro.ICACHE_SIZE type NUMBER */ 

ALTR,implementation = "fast"; /* embeddedsw.CMacro.CPU_IMPLEMENTATION type STRING*/ 

ALTR,pid-num-bits = < 8 >; /* embeddedsw.CMacro.PROCESS_ID_NUM_BITS type NUMBER */ 

ALTR,tlb-num-ways = < 16 >; /* embeddedsw.CMacro.TLB_NUM_WAYS type NUMBER */ 

ALTR,tlb-num-entries = < 256 >; /* embeddedsw.CMacro.TLB_NUM_ENTRIES type NUMBER */ 

ALTR,tlb-ptr-sz = < 8 >; /* embeddedsw.CMacro.TLB_PTR_SZ type NUMBER */ 

ALTR,has-mul; /* embeddedsw.CMacro.HARDWARE_MULTIPLY_PRESENT type NUMBER*/ 

ALTR,reset-addr = < 0xc0000000 >; /* embeddedsw.CMacro.RESET_ADDR type NUMBER */ 

ALTR,fast-tlb-miss-addr = < 0xc8001000 >; /* embeddedsw.CMacro.FAST_TLB_MISS_EXCEPTION_ADDR type NUMBER */ 

ALTR,exception-addr = < 0xc0000020 >; /* embeddedsw.CMacro.EXCEPTION_ADDR type NUMBER */ 

}; //end cpu@0x0 (cpu) 

}; //end cpus 

 

memory@0 { 

device_type = "memory"; 

reg = < 0x08001000 0x00000400 

0x00000000 0x08000000 >; 

}; //end memory@0 

 

sopc@0 { 

device_type = "soc"; 

ranges; 

# address-cells = < 1 >; 

# size-cells = < 1 >; 

compatible = "ALTR,avalon", "simple-bus"; 

bus-frequency = < 50000000 >; 

 

jtag: serial@0x8001440 { 

compatible = "ALTR,juart-12.1", "ALTR,juart-1.0"; 

reg = < 0x08001440 0x00000008 >; 

interrupt-parent = < &cpu >; 

interrupts = < 1 >; 

}; //end serial@0x8001440 (jtag) 

 

timer: timer@0x8001420 { 

compatible = "ALTR,timer-12.1", "ALTR,timer-1.0"; 

reg = < 0x08001420 0x00000020 >; 

interrupt-parent = < &cpu >; 

interrupts = < 0 >; 

clock-frequency = < 50000000 >; 

}; //end timer@0x8001420 (timer) 

}; //end sopc@0 

 

chosen { 

bootargs = "debug console=ttyJ0,115200"; 

}; //end chosen 

}; //end / 

 

And i also made my friend compile my kernel and .sopc file and tried to new zImage but terminal gave me same output :/ 

 

root@F15:~# altera/12.1/nios2eds/bin/nios2-download -g /home/student/Downloads/zImage 

Using cable "USB-Blaster [8-1]", device 1, instance 0x00 

Pausing target processor: not responding. 

Resetting and trying again: FAILED 

Leaving target processor paused 

 

 

I hope you can even help further.  

 

Regards, 

Cem
0 Kudos
Highlighted
Valued Contributor III
3 Views

Hi jpe1313, 

 

This is occelebi. 

 

please email me (occelebi at gmail) because this forum does not let me post anything without admin's approval. I tried to post 5-6 times but they all are pending. It seems all admins are sleeping. I am just able to send one post per thread and not create new topic. :/
0 Kudos
Highlighted
Valued Contributor III
3 Views

Try private messaging me or talk to the admins. I just private messaged you. I will not email you directly.

0 Kudos
Highlighted
Valued Contributor III
3 Views

just for reference, this thread is being continued here: 

http://www.alteraforum.com/forum/showthread.php?t=40606 

 

( www.alteraforum.com / forum / showthread.php?t=40606 )
0 Kudos
Highlighted
Valued Contributor III
3 Views

There is something weird with the moderation on this forum. It seems that the anti-spam system is a bit trigger-happy and puts some users in automatic modding down mode. The problem is that as moderators we don't receive any notification that some posts have been moderated. The posts don't even show as 'new' so most of the time we don't see them when checking the new or updated threads on the forum. I just had a look at the "moderated posts" list on the moderation panel and there is are a lot of old moderated posts that have never been approved... I don't know what to do to make it better unfortunately...

0 Kudos
Highlighted
Valued Contributor III
3 Views

I have to say that it is really boring. I can not even pm anyone because of advertisement block. I would go crazy. This is a official forum so it should be work without any problems. Please deal with this matter. Thanks.

0 Kudos