Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.

Problems with BSP

Altera_Forum
Honored Contributor II
1,296 Views

Hi everyone, 

 

I have build an SOPC system using Quartus 11.1. The system has an on-chip ram. Now, I am using NIOS II - Eclipse platform to build the application. I choose "New NIOS II Application and BSP from template". After adding my SOPC Information file and so far its ok.  

 

Eclipse created two elements at the left side of the panel but no the altera.components.  

When i go to the BSP properties, i can see some errors: 

 

-There are no Drivers in this BSP. 

-File Does not exist C:..\nombre_sopc_project.sopcinfo. 

-SOPC design no set. 

-CPU module no set. 

-The SOPC design does not contain a CPU of a supported architecture. 

-CPU architecture type no set. 

-[Error] altera_hal_linkerx_generator: Required linker section mappings do not exist: "[.entry, . exceptions, .rodata, .rwdata, .text, .bss, .heap, .stack]" 

-BSP not valid. 

 

Or in the attachment. 

 

 

I really appreciate your help.
0 Kudos
4 Replies
Altera_Forum
Honored Contributor II
99 Views

Problem Solved, it was a problem regarding onchip-memory. anyway thanks.

Altera_Forum
Honored Contributor II
99 Views

 

--- Quote Start ---  

Problem Solved, it was a problem regarding onchip-memory. anyway thanks. 

--- Quote End ---  

 

 

 

Hey man, i have same problem with my project, i'm newbie with NIOS II systems. How do you do to solve this problem? 

 

thx.
Altera_Forum
Honored Contributor II
99 Views

 

--- Quote Start ---  

Hey man, i have same problem with my project, i'm newbie with NIOS II systems. How do you do to solve this problem? 

 

thx. 

--- Quote End ---  

 

 

You must add the onchip memory for loading the program. Try this.
Altera_Forum
Honored Contributor II
99 Views

Very clever advise

Reply