Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
12410 Discussions

Quartus II, FSM, Vector waveform file not giving correct output

Altera_Forum
Honored Contributor II
936 Views

Hi there, this is my first post so i'm quite new to this forum.  

 

I have designed a circuit that should give me an output of 1 when it detects an input of 101. For some reason it doesn't seem to be doing that. Can someone tell me why this might be? I have simulated the circuit and there seems to be no problem there. I have attachedd the block diagram file and the vector waveform file.
0 Kudos
2 Replies
Altera_Forum
Honored Contributor II
102 Views

Some additional information. The circuit is operating as intended but the output will never go high due to the correct input never being reached. Can someone please tell me how do i feed the system the correct input? Does all the input need to occur in 1 clock period?

Altera_Forum
Honored Contributor II
102 Views

If the input is asynchronous, then you will probably be violating the setup time on the registers, causing them to go meta-stable. You need to double register the input to ensure you avoid meta-stable inputs.

Reply