Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
12435 Discussions

The eclipse-nios2 won't start.

Altera_Forum
Honored Contributor II
4,374 Views

https://www.kth.se/social/files/54bce182f2765407d5cb1bf5/Sk%C3%A4rmavbild+2015-01-19+kl.+11.47.46_la...  

 

The eclipse-nios2 won't start in Quartus ii version 13.0sp1 installed in Ubuntu 14.04. 

as in the picture when i start the nios2-command_shell from the terminal and then try to open eclipse-nios2 it won't start and nothing shows up. any suggestion?
0 Kudos
10 Replies
Altera_Forum
Honored Contributor II
2,559 Views

u need to run this code in your terminal. 

 

sudo apt-get install libgtk2.0-0:i386
Altera_Forum
Honored Contributor II
2,559 Views

Maybe is time to go for latest 15.0 version already...

Altera_Forum
Honored Contributor II
2,559 Views

 

--- Quote Start ---  

 

 

sudo apt-get install libgtk2.0-0:i386 

--- Quote End ---  

 

 

This worked for me thanks !
FZigu
Novice
2,559 Views

I have the same issue here, but on a windows machine. How do I solve it??

druva1
New Contributor I
2,559 Views

where you able to fix this ?

 

FZigu
Novice
2,559 Views

No!! I threw everything I had at it!! Reinstalled Java, Quartus, Eclipse, nothing! Eclipse won't start as admin even when run from its own folder. When running eclipsec-nios2.exe from the command line (again, as admin), it gives the following message:

 

C:\intelFPGA_lite\19.1\nios2eds\bin>eclipsec-nios2

Error - failed to launch '"C:/intelfpga_lite/19.1/nios2eds/bin/eclipse_nios2/eclipsec.exe" "-pluginCustomization" "C:/intelfpga_lite/19.1/nios2eds/bin/eclipse_nios2/plugin_customization.ini" "-vm" "C:/intelfpga_lite/19.1/quartus//bin64/jre64/bin/java.exe"

 

 

Both files indicated exist. Whatever is happening inside them is failing and I can't figure this out!! Why, Intel, WHY would you use such a shaky platform to build your tools?? I'm going crazy!

 

Like, literally, what I want to do with my FPGA I have to figure out how to do it in Verilog now. Grrrr!!

 

 

druva1
New Contributor I
2,559 Views

Same, I even factory reset my PC and reinstall Java, Eclipse and Quartus and still the eclipse nios wont start. It is quite frustrating -_-

druva1
New Contributor I
2,559 Views

So It finally works for me, I had to downgrade Quartus 18.1 version and now it works, I hope this helps you too.

FZigu
Novice
2,559 Views

YES! It works! I installed Quartus 16.0 just to be sure.

 

This is why no one wants new, updated software!!

 

Thanks druva1, we are in this together!!

 

 

 

Rick1
Beginner
2,356 Views

I am also having this problem with 20.1, it just won't start, it quits immediately. I was trying to upgrade from 18.1. Not sure if it is related but apparently Intel switched from Cygwin to wsl. It tool me an hour to get the nios ii console running, you first have to install wsl, then ubuntu and then several apt-get packages. Only to find out that although the nios console works, eclipse-nios2 still doesn't. This is a real dependency hell.

Reply