OpenCL* for CPU
Ask questions and share information on Intel® SDK for OpenCL™ Applications and OpenCL™ implementations for Intel® CPU
Announcements
This forum covers OpenCL* for CPU only. OpenCL* for GPU questions can be asked in the GPU Compute Software forum. Intel® FPGA SDK for OpenCL™ questions can be ask in the FPGA Intel® High Level Design forum.
1663 Discussions

CL_DEVICE_TYPE_CPU not working in Windows 8.1

Yaknan_G_
Beginner
222 Views

Hi, I recently tried to run my OpenCL program on a new windows 8.1 computer but the program returns an error when the device type is CL_DEVICE_TYPE_CPU. When I change the device type to a CL_DEVICE_TYPE_GPU or CL_DEVICE_TYPE_ ALL it ran the program on the GPU. Here is the system specification of the new computer: OS: Windows 8.1 Processor: Intel Core i7 - 4700MQ clocked at 2.40GHz Display Adapter: Intel HD Graphic 4600 and NVIDIA GeForce GT 740M How can I resolve this problem and is OpenCL having issues with windows 8.1? Please help! Yaknan

0 Kudos
2 Replies
Surbhi_M_Intel
Employee
222 Views

Hi Yaknan,

Thank you for your question. I have tried reproducing this issue on windows 8.1 with the one of existing sample - CapsBasic which query all open CL platforms available on the system and list all devices on a given platform and also with Simple Optimization and didn't see any issue. Can you please try reproducing this problem with the existing samples that will help us find the root cause?
 

Thanks,
-Surbhi

Yaknan_G_
Beginner
222 Views

Hi Surbhi,

sorry for the late reply. Yes, I have seen the CapBasic example from intel and ran it on the same computer with the issue in this post and had the same result(problem). The thing is, there is nothing wrong with the code. To reproduce the issue you have to use a system with Windows 8.1 OS and Intel core i7 4700MQ which is the specs of the system I am using. 

As I said, the problem is not from the code, I got to resolve the issue by downloading the latest version of OpenCL 2.0 2014 Intel release (Test Only version). You can download it from the link here

Thanks!

Yaknan

Reply