OpenCL* for CPU
Ask questions and share information on Intel® SDK for OpenCL™ Applications and OpenCL™ implementations for Intel® CPU
Announcements
This forum covers OpenCL* for CPU only. OpenCL* for GPU questions can be asked in the GPU Compute Software forum. Intel® FPGA SDK for OpenCL™ questions can be ask in the FPGA Intel® High Level Design forum.
1664 Discussions

Code-Builder for OpenCL crashes Visual Studio

Gou__Tokura
Beginner
373 Views

I just tried to run some basic OpenCL examples on a laptop with Intel HD Graphics 4000, but it immediately crashes Visual Studio if I try to get the platform info.

It's strange, because I have the latest versions of Visual Studio and OpenCL SDK.

Does anyone know how to solve this?

 

System information:

OS: Windows 10 Pro

Version: 17.03

OS Build: 15063.786

Microsoft Visual Studio 15.4.0

OpenCL Code Builder - Intel(R) SDK for OpenCL Applications 2017 Beta 7.0.0.2519

Graphics adapter: Intel HD Graphics 4000 which is has OpenCL support.

 

How to replicate:

  1. Launch Microsoft Visual Studio 2017
  2. Code-Builder > Platform Info...
  3. Click Available Machines > (local) [PC_name] > Intel(R) OpenCL > CPU (or GPU)

 

Result:

Visual Studio crashes, produced an error message in a pop-up window (screenshot attached):

"Microsoft Visual Studio 2017 has stopped working.

A problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available."

 

The solution posted on this forum earlier https://software.intel.com/en-us/forums/opencl/topic/603665#comment-1857032 does not seem to work as my machine already has the latest OpenCL SDK.

 

0 Kudos
3 Replies
Gou__Tokura
Beginner
373 Views

I have re-installed Windows and Visual Studio 2017, but I get the same error: VS crashes when I try to click "GPU" or "CPU" in Code Builder's properties window. I have attached more screenshots.

I have managed to run Visual Studio via devenv.exe to make it log its activities into a log file.

Here are some relevant parts of the log:

A crash in a previous session has been detected. Stack follows:
...
Unexpected system error mode before loading package [Microsoft.VisualStudio.Shell.Connected.ConnectedUser.ConnectedUserPackage]

Begin package load [IntelGfxDbgPackage]

End package load [IntelGfxDbgPackage]

C:\Program Files (x86)\Microsoft Visual Studio\2017\Enterprise\Common7\IDE\Extensions\sme5cbyu.1dp\CodeBuilderSessionManager.dll!Intel.CodeBuilderSessionManager.PlatformInfoTree.SetDeviceInfoProperties ExtensionCrashNotification

C:\Program Files (x86)\Microsoft Visual Studio\2017\Enterprise\Common7\IDE\Extensions\sme5cbyu.1dp\CodeBuilderSessionManager.dll!Intel.CodeBuilderSessionManager.PlatformInfoTree.TreeView_SelectedItemChanged ExtensionCrashNotification

C:\Program Files (x86)\Microsoft Visual Studio\2017\Enterprise\Common7\IDE\Extensions\sme5cbyu.1dp\CodeBuilderSessionManager.dll!Intel.CodeBuilderSessionManager.PlatformInfoTree.OnPreviewMouseLeftButtonDown ExtensionCrashNotification

 

Doerner__Edgardo
Beginner
373 Views

Maybe it is quite late but I had the same issue (with Visual Studio 2017 and latest Intel OpenCL SDK), the solution was to install the driver for the Intel HD 4000 from here: https://downloadcenter.intel.com/product/81499/Intel-HD-Graphics-4000

I have a Lenovo Thinkpad Twist with an Intel Core i5 3317U and an Intel HD 4000

Michael_C_Intel1
Moderator
373 Views

TokuraG,

Thanks for the screen shots and the detailed log. Three comments:

1) As with many Win apps, VS is known for editing the registry extensively. If perhaps, you experienced an irregularity w.r.t. Intel® SDK for OpenCL™ Applications install or MSVS install, reinstalling could be an opportunity to resolve obscure registry related issues.

2) It's possible that there's an issue with your driver install. As far as OpenCL™ implementation goes, note the Intel® SDK for OpenCL™ Applications  comes with an OpenCL™CPU only implementation. For Win systems, the OpenCL graphics coprocessor implementation is currently distributed as part of the Graphics Driver installer. You can access it via your particular part's page here: here: https://downloadcenter.intel.com/product/72056/Intel-Core-i5-3230M-Processor-3M-Cache-up-to-3-20-GHz...

See: Intel® Graphics Driver for Baytrail and 3rd generation (15.33.46.4885)

3) Lastly, I have filed your sighting for the dev team... The error log feedback is pretty specific and could prove helpful. We'll ask if the plugin developers can identify any gaps that could have lead to your observation.

Reply