OpenCL* for CPU
Ask questions and share information on Intel® SDK for OpenCL™ Applications and OpenCL™ implementations for Intel® CPU
Announcements
This forum covers OpenCL* for CPU only. OpenCL* for GPU questions can be asked in the GPU Compute Software forum. Intel® FPGA SDK for OpenCL™ questions can be ask in the FPGA Intel® High Level Design forum.
1663 Discussions

Error when running aocl install

SICILIANO__NIKOLAS
895 Views

Below is the terminal command and all output for running aocl install on s10_ref supplied with the FPGA SDK for OpenCL for Ubuntu. Some of the install works, then it crashes for the reasons given below.

To try and fix the error, I reinstalled linux-headers-generic but it did not fix the error. Thank you for any help with this issue.

sudo env "PATH=$PATH" aocl install .
Do you want to setup the FCD at directory /opt/Intel/OpenCL/Boards [Y/n] y
aocl install: Setting up the FPGA Client Driver (FCD) to the system. This process may require admin privilege
Install the FCD file to /opt/Intel/OpenCL/Boards
aocl install: Adding the board package /home/niko/intelFPGA_pro/19.4/hld/board/s10_ref to the list of installed packages
Installing the board package driver to the system.
aocl install: Running install from /home/niko/intelFPGA_pro/19.4/hld/board/s10_ref/linux64/libexec
Looking for kernel source files in /lib/modules/5.3.0-45-generic/build
Using kernel source files from  /lib/modules/5.3.0-45-generic/build
Building driver for BSP with name s10_ref
make: Entering directory '/usr/src/linux-headers-5.3.0-45-generic'
  CC   /tmp/opencl_driver_s5Q4ey/aclpci_queue.o
  CC   /tmp/opencl_driver_s5Q4ey/aclpci.o
/tmp/opencl_driver_s5Q4ey/aclpci.c: In function ‘load_signal_info’:
/tmp/opencl_driver_s5Q4ey/aclpci.c:371:26: error: initialization from incompatible pointer type [-Werror=incompatible-pointer-types]
   struct siginfo *info = &aclpci->signal_info;
                          ^
/tmp/opencl_driver_s5Q4ey/aclpci.c:382:8: error: assignment from incompatible pointer type [-Werror=incompatible-pointer-types]
   info = &aclpci->signal_info_dma;
        ^
cc1: some warnings being treated as errors
scripts/Makefile.build:288: recipe for target '/tmp/opencl_driver_s5Q4ey/aclpci.o' failed
make[1]: *** [/tmp/opencl_driver_s5Q4ey/aclpci.o] Error 1
Makefile:1655: recipe for target '_module_/tmp/opencl_driver_s5Q4ey' failed
make: *** [_module_/tmp/opencl_driver_s5Q4ey] Error 2
make: Leaving directory '/usr/src/linux-headers-5.3.0-45-generic'
aocl install: failed.
aocl install: Removing FCD
aocl install: Removing the board package /home/niko/intelFPGA_pro/19.4/hld/board/s10_ref from the list of installed packages

0 Kudos
6 Replies
Sergey_I_Intel1
Employee
895 Views

Hi Nikolas,

 

What is your Ubuntu version and Linux kernel version?

 

Best regards,

Sergey

SICILIANO__NIKOLAS
895 Views

Hi Sergey,

Ubuntu version is 18.04.1 and my kernel version is 5.3.0-45-generic.

Thanks,

Nick

Sergey_I_Intel1
Employee
895 Views

Hi Nikolas,

 

Try to downgrade your kernel to 4.15 and install sources and headers for 4.15.

This should help.

 

Best regards,

Sergey

Saikiranbelana
403 Views

Iam trying to run some examples provide at Intel Documentation with Intel PAC card plugged in to PCIe slot, but when I run the following command on a docker container, It shows the following message and doesn't install properly. I'm not able to program or run any examples.

aocl install
root@bac2b2449b6a:~/a10_gx_pac_ias_1_2_1_pv_rte_installer/components# aocl install
Do you want to setup the FCD at directory /opt/Intel/OpenCL/Boards [Y/n] Y
aocl install: Setting up the FPGA Client Driver (FCD) to the system. This process may require
admin privilege
Install the FCD file to /opt/Intel/OpenCL/Boards  
aocl install: Adding the board package /root/intelrtestack/a10_gx_pac_ias_1_2_1_pv/opencl/ope
ncl_bsp to the list of installed packages
Installing the board package driver to the system.
aocl install: Running install from /root/intelrtestack/a10_gx_pac_ias_1_2_1_pv/opencl/opencl_
bsp/linux64/libexec
WARNING: Intel PAC device not found



When I run,  

aocl diagnose

I'm getting the following output, 

root@bac2b2449b6a:~/a10_gx_pac_ias_1_2_1_pv_rte_installer/components# aocl diagnose
--------------------------------------------------------------------
ICD System Diagnostics                                              
--------------------------------------------------------------------

Using the following location for ICD installation: 
        /etc/OpenCL/vendors

Found 1 icd entry at that location:
        /etc/OpenCL/vendors/Altera.icd

the following OpenCL libraries are referenced in the icd files:
        libalteracl.so

checking LD_LIBRARY_PATH for registered libraries:
        libalteracl.so was registered on the system at /opt/opencl_rte/aclrte-linux64/host/linux64/lib

Using the following location for fcd installations:
        /opt/Intel/OpenCL/Boards

Found 1 fcd entry at that location:
        /opt/Intel/OpenCL/Boards/dcp_bsp.fcd

the following OpenCL libraries are referenced in the fcd files:
        /root/intelrtestack/a10_gx_pac_ias_1_2_1_pv/opencl/opencl_bsp/linux64/lib/libintel_opae_mmd.so

checking LD_LIBRARY_PATH for registered libraries:
        /root/intelrtestack/a10_gx_pac_ias_1_2_1_pv/opencl/opencl_bsp/linux64/lib/libintel_opae_mmd.so was registered on the system.

ERROR: OpenCL host failed
--------------------------------------------------------------------
ICD diagnostics FAILED                                              
--------------------------------------------------------------------
--------------------------------------------------------------------
BSP Diagnostics                                                     
--------------------------------------------------------------------
--------------------------------------------------------------------
Warning:
No devices attached for package:
/root/intelrtestack/a10_gx_pac_ias_1_2_1_pv/opencl/opencl_bsp
--------------------------------------------------------------------
Vendor: Intel Corp

No active device installed on the host machine.
      Please consult documentation for troubleshooting steps

DIAGNOSTIC_FAILED
--------------------------------------------------------------------

Call "aocl diagnose <device-names>" to run diagnose for specified devices
Call "aocl diagnose all" to run diagnose for all devices

 

the FPGA is getting detected when I run 

fpgainfo fme
root@bac2b2449b6a:~/a10_gx_pac_ias_1_2_1_pv_rte_installer/components# fpgainfo fme
Board Management Controller, microcontroller FW version 26895
Last Power Down Cause: POK_CORE
Last Reset Cause: None
//****** FME ******//
Object Id                     : 0xF000000
PCIe s:b:d:f                  : 0000:86:00:0
Device Id                     : 0x09C4
Socket Id                     : 0x00
Ports Num                     : 01
Bitstream Id                  : 0x124000200000367
Bitstream Version             : 1.2.4
Pr Interface Id               : 38d782e3-b612-5343-b934-2433e348ac4c
Boot Page                     : user

 

can you please help me in resolving the errors?

Quant_Geek
Beginner
895 Views

Hi Nikolas,

You will need to make some changes to the drivers to get it to install in Ubuntu 18.04, but its doable.  I have it running on my machine with kernel 5.3.0. See

Regards,

QG

nikhl
Novice
476 Views

Hi QG,

can you please elaborate what are the steps to do to work aocl install on 5.3.0.45

regards
Nikhil

Reply