OpenCL* for CPU
Ask questions and share information on Intel® SDK for OpenCL™ Applications and OpenCL™ implementations for Intel® CPU
Announcements
This forum covers OpenCL* for CPU only. OpenCL* for GPU questions can be asked in the GPU Compute Software forum. Intel® FPGA SDK for OpenCL™ questions can be ask in the FPGA Intel® High Level Design forum.
1663 Discussions

Intel OpenCL CPU only runtime version 7.* and maximum kernel length crash

Achille_P_
Beginner
561 Views

Hi,

we noticed that the new Intel OpenCL CPU only runtime series 7.* crashes in its OclCpuBackEnd64.dll during the clBuildProgram() method when a rather long source code is passed. The very same piece of code is working properly under the previous versions of the Intel OpenCL CPU only runtime (version 6.* and earlier), as well as under the NVidia, AMD, and Intel GPU runtime. 

By cutting a few dozen lines of code, the clBuildProgram() works. 

We are facing this problem under all the 7.* CPU only versions we can test in our firm:

- 7.0.* (the one available as Experimental through the Intel OpenCL SDK)
- 7.2.* (as the CPU only runtime available with the HD Graphics driver)
- 7.5.* (as the CPU only runtime availabe with another Intel GPU)

 

 

0 Kudos
5 Replies
Jeffrey_M_Intel1
Employee
561 Views

Thanks for this report.  The team will be glad to investigate this bug, but to do so we will need kernel source showing this problem as a reproducer.  If there are any concerns with posting to a public forum you can use the "send author a message" link by my name to send a private message.

Achille_P_
Beginner
561 Views

Jeffrey M. (Intel) wrote:

Thanks for this report.  The team will be glad to investigate this bug, but to do so we will need kernel source showing this problem as a reproducer.  If there are any concerns with posting to a public forum you can use the "send author a message" link by my name to send a private message.

Hi Jeffrey,

thanks for your answer. I've no problem in privately sending you the code snippet, but I can't find the "send message" option you mentioned. I can drop you an email if you provide me your address.

Jeffrey_M_Intel1
Employee
561 Views

If you are logged in to the forum, you can find "send author a message" above this post.  

Alternately, if this does not work for any reason, my email is jeffrey.mcallister@intel.com.

Achille_P_
Beginner
561 Views

Jeffrey M. (Intel) wrote:

If you are logged in to the forum, you can find "send author a message" above this post.  

Alternately, if this does not work for any reason, my email is jeffrey.mcallister@intel.com.

Nada, I only have "quote" and the post number. Maybe Chrome is not friendly enough. Will send you an email right now, thanks.

Jeffrey_M_Intel1
Employee
561 Views

Thanks for sending your reproducer. The bug is filed.  

Reply