OpenCL* for CPU
Ask questions and share information on Intel® SDK for OpenCL™ Applications and OpenCL™ implementations for Intel® CPU
Announcements
This forum covers OpenCL* for CPU only. OpenCL* for GPU questions can be asked in the GPU Compute Software forum. Intel® FPGA SDK for OpenCL™ questions can be ask in the FPGA Intel® High Level Design forum.

LLVM Error

nick_m_
Beginner
493 Views

Hello all,

Recently I acquired a new laptop, and i've been unable to run any of my OpenCL code on it - I get the following error:

LLVM ERROR: Unknown error while opening the igdclbif.bin

The laptop is an Acer S5 with an Intel i3 & Intel graphics 520. I immediately assumed that the graphics driver was to blame, and attempted to update it; however apparently the most recent driver available is installed - 21.20.16.4550.

I've been unable to find mention of this error on the forums; Does anyone have any idea what could be causing it/Suggests to solve it?

Thanks all.

0 Kudos
1 Solution
Jeffrey_M_Intel1
Employee
493 Views

You may want to take this topic to Acer.  I've confirmed that this is a 15.45 driver, but the build # does not show up on the list of driver packages from downloadcenter.intel.com.  I see a build 4552 and 4542, but no 4550.  Your driver package is probably from your OEM, which means your OEM would also provide the updates. 

I can confirm that 21.20.16.4542 is working on my test laptop with Intel HD Graphics 520. 

View solution in original post

3 Replies
Jeffrey_M_Intel1
Employee
494 Views

You may want to take this topic to Acer.  I've confirmed that this is a 15.45 driver, but the build # does not show up on the list of driver packages from downloadcenter.intel.com.  I see a build 4552 and 4542, but no 4550.  Your driver package is probably from your OEM, which means your OEM would also provide the updates. 

I can confirm that 21.20.16.4542 is working on my test laptop with Intel HD Graphics 520. 

nick_m_
Beginner
493 Views

Interesting, thank you. I'll see if I can find an older/newer driver to install.


Thank you Jeffery

nick_m_
Beginner
493 Views

Just to close the thread up - Issue must be with Acer's driver, I forced the .4542 intel driver to install, and OpenCL now works correctly.

 

Thanks for your help Jeffery

Reply