OpenCL* for CPU
Ask questions and share information on Intel® SDK for OpenCL™ Applications and OpenCL™ implementations for Intel® CPU
Announcements
This forum covers OpenCL* for CPU only. OpenCL* for GPU questions can be asked in the GPU Compute Software forum. Intel® FPGA SDK for OpenCL™ questions can be ask in the FPGA Intel® High Level Design forum.
1663 Discussions

Offline compile fails with CL_DEVICE_NOT_FOUND

rossini__giuseppe
283 Views

Hi everyone, 

I am trying to play with the OpenCL SDK for Intel. I am able to compile an OpenCL program with gcc and list all the available platforms and run a simple addition kernel. 

However, if I try to use the offline compiler ioc64, this is what I get:

Failed to get OpenCL device...: -1 (CL_DEVICE_NOT_FOUND)
Build failed!
 
As I said, the simpleAdd.c program works, and clinfo recognizes all the different platforms. 
 
-- What I installed --
I installed the neo runtime driver from here (I also installed the libva support): 
 
And the sdk from here:
 
Worth mentioning: during the installation, the installer was warning me that my GPU is not supported. 
 
-- My configuration --
I have a coffee lake i7 8700k CPU and I am running on Ubuntu mate 18.07. 
 
Any idea or suggestions about why the offline compiler is misbehaving? They link with the same libraries, so I really don't understand why the difference. 
 
I also saw this other thread: 
 
But none of the solutions mentioned there helped me. 
 
Thanks a lot for any suggestion,
Giuseppe
0 Kudos
4 Replies
Michael_C_Intel1
Moderator
283 Views

Hi GiuseppeR,

Thanks for speaking to your experience.

The tool chain is validated on Ubuntu 16.04... that being said... it's desirable to have future LTS or supported OS's function. Note the Intel Graphics Compute Runtime for OpenCL Driver (NEO)  has it's requirements on it's github page. Also, be sure to check the FAQ and LIMITATIONS docs on the github for the most complete picture.

Can you share your offline compiler toggles or command line?

Is the SDK you used the 2017 R2 version or part of the Intel System Studio 2019 beta? Have you seen the same results with both? Intel System Studio 2019 Beta is very much so work in progress and would be most appropriate for me to report a sighting for.

-MichaelC

 

rossini__giuseppe
283 Views

Hi Michael, 

Thanks a lot for your reply.

What surprises me is that I am able to use OpenCL+gcc, but not the ioc64. I presume they are linking against the same libOpenCL library, so it must be something in the libgen_info. 

I downloaded the 2017 R2 version. I will try with Intel System Studio 2019 beta as well. 

As for limitations and restrictions, I was aware that Ubuntu 18.07 was an unexplored land, but I was hoping for forward compatibility :)

This is the command I am using:

$ ioc64 -input=simpleAdd.cl  -asm -device=gpu

Is there any way to understand a bit deeper what is going under the hood?

Thanks once more.

Giuseppe

 

rossini__giuseppe
283 Views

Hi again, 

Good news here: I tried with Intel System Studio and ioc64 (same flags) magically worked!

I was also able to run the Code Builder from Eclipse. 

Thanks a lot for your help Michael.

Regards,

Giuseppe

Michael_C_Intel1
Moderator
283 Views

Hello GiuseppeR... Thanks for the update.

Some follow up...

Intel® System Studio XE 2019 Beta contains the Intel® SDK for OpenCL™ Applications 2019 Beta. If you're using the Intel® Graphics Compute Runtime for OpenCL™ Driver (a.k.a. NEO) on Linux* OS, the 2017 SDK tools are not designed with that OpenCL™ implementation in mind... however the 2019 SDK has been designed to support NEO.

The ioc64 offline compiler is a pass through tool that looks for Intel implementations available on the system. The NEO implementation is too new for the 2017 ioc64 tool.

 

-MichaelC

Reply