OpenCL* for CPU
Ask questions and share information on Intel® SDK for OpenCL™ Applications and OpenCL™ implementations for Intel® CPU
Announcements
This forum covers OpenCL* for CPU only. OpenCL* for GPU questions can be asked in the GPU Compute Software forum. Intel® FPGA SDK for OpenCL™ questions can be ask in the FPGA Intel® High Level Design forum.
1663 Discussions

Running Open Cl implementation for Sobel on CPU

sraha
Beginner
231 Views

Hello,

 

I followed Intel tutorial on the following link:

https://software.intel.com/en-us/INDE-OpenCL-Sobel ( run Sobel using OpenCl )

It ran successfully on GPU. However, when I changed the command line arguments from GPU to CPU and also changed the device to CPU, it didn't work. I got the following error: 

Error 1 error MSB3721: The command ""C:\Intel\OpenCL\sdk\bin\x86\ioc32.exe" -cmd=build -input=".......Visual Studio 2013\Projects\Sobel_OCL\SobelKernels.cl" -output="Debug\SobelKernels.out" -VS -device=CPU -simd=default -targetos=current            -bo="           "" exited with code -1073741819. C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V120\BuildCustomizations\IntelOpenCL.targets 98 5 Sobel_OCL.
 
Although the usage of this program says: " Usage: Sobel [num test iterations] [cpu|gpu] [intel|amd|nvidia] [SurfWidth(^2 only)] [SurfHeight(^2 only)] [show_CL | no_show_CL".
 
What should I do to run the code on CPU only? knowing that I installed CPU only runtime for OpenCL.
 
Any help and suggestion are highly appreciated.
 
Thanks,
Samah

 

 

 

https://software.intel.com/en-us/INDE-OpenCL-Sobel

0 Kudos
1 Reply
Michael_C_Intel1
Moderator
231 Views

SamahR,

However, when I changed the command line arguments from GPU to CPU and also changed the device to CPU, it didn't work.

 

Can you explain what you changed exactly where? I don't follow... Was it at project level?

If you're on a system with Intel® Graphics and have it's driver package installed... that should come with both CPU and Intel Graphics OpenCL implementations. ioc64 or ioc32 should serve as pass through to the respective Intel implementations when -device= is used.

Can you execute the offline compiler front end command in the error listed by hand? That might provide some hints. Perhaps the install paths are different. Could be many things.

 

 

-MichaelC

Reply