OpenCL* for CPU
Ask questions and share information on Intel® SDK for OpenCL™ Applications and OpenCL™ implementations for Intel® CPU
Announcements
This forum covers OpenCL* for CPU only. OpenCL* for GPU questions can be asked in the GPU Compute Software forum. Intel® FPGA SDK for OpenCL™ questions can be ask in the FPGA Intel® High Level Design forum.
1668 Discussions

Segflt when running all Intel OpenCL code samples.

mroge7
Beginner
221 Views

Hi,

I get a segflt when running Intel OpenCL code samples.  In fact, i have never successfully run _any_ OpenCL examples.

I'm using: 
S/W: Fedora 25 running unmodified Fedora kernel 4.12.11-200.fc25.x86_64
H/W : Processor: E3-1505L v5 (Skylake)  PCH: CM238

Web sites I've been referring to for help:

https://software.intel.com/en-us/articles/opencl-drivers
https://software.intel.com/en-us/intel-opencl-support/code-samples

The packages/versions of Intel OpenCL I’m using are:
 
intel-opencl-cpu-r4.1-61547.x86_64
intel-opencl-devel-r4.1-61547.x86_64
intel-opencl-r4.1-61547.x86_64

I have basically followed  http://registrationcenter-download.intel.com/akdlm/irc_nas/11396/intel-opencl-4.1-installation.pdf
However, It’s unclear if I need to patch my kernel.  I tried applying the supplied patch (kernel-4.7.patch), but  applying it 
to my kernel (4.12.11) appears to be very difficult or impossible.

Examples of some of the programs I unsuccessfully tried:
 
 1.  https://software.intel.com/sites/default/files/managed/59/01/intel_ocl_gemm.zip  
After unzipping, it compiles OK; but running it gives a Segflt:
 
sh-4.3# ./GEMM -p 0 -d 1
Platforms (1):
    [0] Intel(R) OpenCL [Selected]
Devices (2):
    [0] Intel(R) Xeon(R) CPU E3-1505L v5 @ 2.00GHz
    [1] Intel(R) HD Graphics [Selected]
Build program options: "-DT=float -DTILE_SIZE_M=1 -DTILE_GROUP_M=16 -DTILE_SIZE_N=128 -DTILE_GROUP_N=1 -DTILE_SIZE_K=8"
Segmentation fault (core dumped)

sh-4.3# ./GEMM -p 0 -d 0
Platforms (1):
    [0] Intel(R) OpenCL [Selected]
Devices (2):
    [0] Intel(R) Xeon(R) CPU E3-1505L v5 @ 2.00GHz [Selected]
    [1] Intel(R) HD Graphics
Segmentation fault (core dumped)
 

 2.  intel_ocl_median_filter.zip
Same thing- compiles, but segflt when running.
 

 3.  intel_ocl_tone_mapping_multidevice.zip  
Same thing – segflt when running:
 
sh-4.3# pwd
/root/opencl.examples/tone.mapping/ToneMappingMultiDevice
sh-4.3# ./ToneMappingMultiDevice  -t gpu
Platforms (1):
    [0] Intel(R) OpenCL [Selected]
CalculateFStopsParameter result = 0.379187
Trying to run on Processor Graphics
Segmentation fault (core dumped)
sh-4.3# ./ToneMappingMultiDevice  -t cpu
Platforms (1):
    [0] Intel(R) OpenCL [Selected]
CalculateFStopsParameter result = 0.379187
Trying to run on CPU
Segmentation fault (core dumped)


Question 1 Is this version expected to work with my hardware/CPU/GPU ?
Question 2 Is this expected to work with my 4.12, unpatched, kernel ?
Question 3 wondering if moving to a later version of the above three OpenCL packages would make a difference ?
 
Thanks a lot!
Martin Rogers


 

0 Kudos
1 Reply
mroge7
Beginner
221 Views

Well -  strace showed me that the apps wanted libtinfo.so.5 whereas my Fed 25 system had ver 6.

Further looking I found that the package ncurses-compat-libs contained this- adding this package makes all the 

above examples run successfully.

 

Reply