OpenCL* for CPU
Ask questions and share information on Intel® SDK for OpenCL™ Applications and OpenCL™ implementations for Intel® CPU
Announcements
This forum covers OpenCL* for CPU only. OpenCL* for GPU questions can be asked in the GPU Compute Software forum. Intel® FPGA SDK for OpenCL™ questions can be ask in the FPGA Intel® High Level Design forum.
1663 Discussions

clBuildProgram crashes for Xeon Phi

PouryaShirazian
Beginner
245 Views

Hi, 

I have installed a Xeon Phi on CentOS 6.6. When running my OpenCL application on Intel SDK it works for CPU but crashes when I select the Xeon Phi which shows as "Intel(R) Many Integrated Core Acceleration Card". libOpenCL points to "/opt/intel/opencl/lib64/libOpenCL.so" on my system. 

Please advise. 

 

0 Kudos
5 Replies
Yuri_K_Intel
Employee
245 Views
Hi, Which versions of Intel OpenCL runtime and MPSS do you use? Supported/verified versions for Xeon Phi are: Intel OpenCL runtime - 14.2 Intel MPSS - 3.3.x Thanks, Yuri
PouryaShirazian
Beginner
245 Views

MPSS version is 3.5.1. OpenCL version is 14.2 though. 

Thanks

Yuri_K_Intel
Employee
245 Views
MPSS 3.5.1 hasn't been tested/validated with OpenCL at Xeon Phi. So, I'd recommend switching to a supported version - 3.3.x. Thanks, Yuri
PouryaShirazian
Beginner
245 Views

So I installed mpss 3.3.5 and Opencl SDK 14.2. and running micinfo produces the following output:

 System Info
                HOST OS                 : Linux
                OS Version              : 2.6.32-504.el6.x86_64
                Driver Version          : 3.3.5-1
                MPSS Version            : 3.3.5
                Host Physical Memory    : 7999 MB

Device No: 0, Device Name: mic0

        Version
                Flash Version            : 2.1.02.0391
                SMC Firmware Version     : 1.17.6900
                SMC Boot Loader Version  : 1.8.4326
                uOS Version              : 2.6.38.8+mpss3.3.5
                Device Serial Number     : ADKC45000259

but my application now fails to create a command-q:

Requested device: Intel(R) Many, Found: Intel(R) Many Integrated Core Acceleration Card
ERROR: [/src/benchapp.cpp:148] TIME: [Fri Aug 14 23:02:20 2015] Failed to create a commandQ for device 1

 

PouryaShirazian
Beginner
245 Views

I fixed the issue by exporting some env variables:

export LD_LIBRARY_PATH=/opt/intel/opencl-1.2-4.5.0.8/lib64/:$LD_LIBRARY_PATH
export MIC_LD_LIBRARY_PATH=/opt/intel/opencl-1.2-4.5.0.8/libmic/:$MIC_LD_LIBRARY_PATH

 

Also I need to set intel.icd file under /etc/OpenCL/vendors/intel.icd

The content of that file is as folllowing:

/opt/intel/opencl-1.2-4.5.0.8/lib64/libintelocl.so

 

 

 

Reply