OpenCL* for CPU
Ask questions and share information on Intel® SDK for OpenCL™ Applications and OpenCL™ implementations for Intel® CPU
Announcements
This forum covers OpenCL* for CPU only. OpenCL* for GPU questions can be asked in the GPU Compute Software forum. Intel® FPGA SDK for OpenCL™ questions can be ask in the FPGA Intel® High Level Design forum.
1663 Discussions

project creation failed - Visual Studio 2010

ahunt191
Beginner
400 Views
I installedIntel SDK for OpenCL* Applications 2012 and I am having a problem creating a new OpenCL project in Visual Studio 2010. I followed the instructions located here:http://software.intel.com/sites/landingpage/opencl/user-guide/Creating_new_OpenCL_Project_Template.h.... At the bottom of my window, I see this message: "Creating project 'OpenCLProject1'... project creation failed". This is a fresh installation of Windows 7 Ultimate, Visual Studio 2010 Pro (complete installation) and the OpenCL SDK. I have no problem creating other projects. Any help debugging this problem will be greatly appreciated.
0 Kudos
1 Solution
Oded_P_Intel
Employee
400 Views

Please replace the line:
Wizard=VsWizard.VsWizardEngine.9.0
with this line:
Wizard=VsWizard.VsWizardEngine.10.0
In the file OpenCLProj.vsz located in "C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\vcprojects\OpenCL".
This should fix that issue.
This fix will be included in the next Intel SDK for OpenCL+ Applications release.

Best Regards,
Oded

View solution in original post

8 Replies
Uri_L_Intel
Employee
400 Views

Hello,

Can you please provide the Windows version that youre using (32-bit or 64-bit) and the SDK version (32/64) that you installed?

Thanks,
Uri

ahunt191
Beginner
400 Views
Both Windows and the SDK are 64-bit. To make sure I had everything installed properly, I downloaded the OpenCL samples. I can open, compile and run all of the samples in VS 2010.
Uri_L_Intel
Employee
400 Views

Thanks,

To work with the plug-in on 64-bit OS, Microsoft Visual Studio must be configured for 64-bit applications, including 64-bit compiler and tools (stated in our release notes).
Can you please make sure that the required software is installed?

Thanks,
Uri

ahunt191
Beginner
400 Views
When I installed VS2010, I installed the 64 bit libs and compiler. I found these instructions on how to configure a project for 64-bit.
The problem is the instructions assume you can create a project. Unfortunately, I can't.
I tried to get some information from the VS log, but I don't see anything that can help. The only entries that mention of Intel or OCL are these three.
93
Information
Extension Manager
Successfully loaded extension...
C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\Extensions\Intel\OCLExtension\0.2\
94
Information
Extension Manager
Extension is enabled...
C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\Extensions\Intel\OCLExtension\0.2\
93 Information Extension Manager Successfully loaded extension... C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\Extensions\Intel\OCLExtension\0.2\ 94 Information Extension Manager Extension is enabled... C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\Extensions\Intel\OCLExtension\0.2\
147
Information
Microsoft.VisualStudio.CommonIDE.ExtensibilityHosting.VsShellComponentModelHost
Successfully loaded component assembly from cache
C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\Extensions\Intel\OCLExtension\0.2\OCLExtension.dll
Thanks again for your help.
an_lu
Beginner
400 Views
I have the same problem with Intel SDK for OpenCL+ Applications 2012 (64-bit) on a 64-bit Windows machine and Visual Studio 2010 Ultimate. The OpenCL-project can't be created from the template.
Raghupathi_M_Intel
400 Views
I installed everything fresh (OS, VS2010, OCL SDK) and was able to reproduce this issue. I will get back to you on a possible solution/workaround soon.

Thanks,
Raghu
Oded_P_Intel
Employee
401 Views

Please replace the line:
Wizard=VsWizard.VsWizardEngine.9.0
with this line:
Wizard=VsWizard.VsWizardEngine.10.0
In the file OpenCLProj.vsz located in "C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\vcprojects\OpenCL".
This should fix that issue.
This fix will be included in the next Intel SDK for OpenCL+ Applications release.

Best Regards,
Oded

heba_f_
Beginner
400 Views

hi i have installed VS 2010 and CUDA tool kit 4.2
,i did all the steps ;but when i try to crate anew project in VC++ and choose Opencl this message appears "parameter toolFile cannot be null" ; what is going wrong !!!!!!!

Reply