Processors
Intel® Processors, Tools, and Utilities
14989 Discussions

600 series Chipset Family PCH Wake Alarm Device Timer problem

Time229
Novice
3,282 Views

     First of all, I welcome any suggestions of a better forum to post this issue on, but wasn't sure where chipsets would fall.  I recently purchased several new ASRock Z690 based boards and also an Asus W680 based board.  After installing Windows 11 Pro 22H2 I discovered a common problem with all of them regarding wake timers set by the OS- they are always late.  But I don't just mean by a small fixed amount, the delay after the target wake time increases the longer that the system is asleep before the target wake time.  For example, if I use Windows Task Scheduler to create a wakeup event 12 hours from now and put the system to sleep, it doesn't wake until 12 hours and roughly 7 minutes have elapsed, with 24 hours asleep being almost 15 minutes late, etc.
    At first I figured it was a BIOS problem and sent a contact form to ASRock support, unfortunately they have not yet responded. Then I purchased the Asus Z680 based board, figuring I could at least get my DVR system working again since it was sometimes now missing 15 minutes of a half hour show since the Z690 'upgrade'.  That's when I found that even this board was doing the same thing.  I know those two companies are somewhat related, but now I'm not sure the problem is with BIOS.  I only recently started a ticket with Asus for this issue.

   It's my [limited] understanding that the OS would place a value for the next wake event in the PCH 'Wake Alarm Device Timer' registers sometime before the system goes into S3/S4.  Assuming this value is correct, and of course the chipset is functioning properly, then system should wake at the proper time.  But since it does not, and the same problem appears from two different manufactures, there must be some common thread.

  I previously had several X99 based boards also running Windows 11 and never had this problem, but I also understand that this in and of itself does not rule out Windows as the problem now. 

I guess I'm hoping that someone with a better understanding than myself of how the OS would interact with the PCH to set this wake timer, and better where specifically to look to find out what's going wrong.  I tried to search online to find anyone else experiencing this problem and was surprised to find nothing, considering that I now have 7 boards of three models and two manufacturers all doing the same thing.

0 Kudos
10 Replies
Jocelyn_Intel
Employee
3,109 Views

Hello, @Time229  

 

Thank you for posting on the Intel® communities.  

 

I am sorry to hear what is happening with your PC, however, you need to contact your OS developer for further assistance and report this issue. 

 

This thread will no longer be monitored but we hope that other fellow members can jump in and give advice that might help you. 

 

Best regards,  

Jocelyn M.   

Intel Customer Support Technician. 


0 Kudos
madbrain
Novice
2,788 Views

Did you ever resolve this ?

I'm experiencing the same problem with two Asus intel boards, Z690 and Z790, and Windows 10 Pro.

The wake timers run about once every 24 hours and appear to be almost exactly 10 minutes late.

This is terrible since one of the PC is used as a DVR to record TV programs, and they need to be uptime.

Both machines also are supposed to backup to a NAS that is waken up by WOL at 2am, but the backup actually starts at 2:10am.

I "upgraded" from an AMD-based system which didn't have this issue. And I have had this problem ever since.

I believe this is is an Intel firmware issue that really needs to be addressed.

0 Kudos
Time229
Novice
2,779 Views
Hello Madbrain,
 
    No, I never found an answer yet.  Intel told me to contact my 'OS' supplier and closed out the case, and I got nowhere with Microsoft.  I had jumped from X99 systems right to the Z690s.  I subsequently obtained some used motherboards just for experimentation and it seems this problem actually started with the 300 series chipsets.  It appears to have something to do with the 'ACPI Wake Alarm Device' that appears under system devices in the device manager, which was not in the 200 series and earlier chipsets, but is in the 300 and later series.
 
I myself honestly don't know if this is an Intel design flaw or a Microsoft driver problem, but I agree someone needs to address it.
 
I just got so frustrated wasting time trying to explain the problem but getting nowhere with ASRock, Microsoft and Intel that I just gave up and purchased a new AMD X570 system for my DVR, so the new ASRock Z690 board and i9-12900K are now just sitting in a box, what a waste!
 
Now, I also have to use that to send magic packets to wake the other Z690s whenever I need them to do scheduled backups, etc.  Trust me, I know exactly what you're going through, and if you can get anyone to pay attention I'll be glad to share also,
 
Time229
madbrain
Novice
2,728 Views

Time229,

I started another thread at https://community.intel.com/t5/Processors/Wake-timers-10-minutes-late-on-Z690-Z790-boards/m-p/1538130/emcs_t/S2h8ZW1haWx8dG9waWNfc3Vic2NyaXB0aW9ufExPOTRPRjNURlJCUjJFfDE1MzgxMzB8U1VCU0NSSVBUSU9OU3xoSw . I am hoping to get Intel to pay attention. So far the Intel rep who responded said this needs to be reported to my OS vendor.

This RTC clock issue is really unacceptable behavior. And it seems to be common to a number of Intel chipsets, multiple brands of motherboards, and multiple versions of Windows, and many different CPUs.

Have you by any chance experimented with wake timers under Linux  ? I'm trying a live CD with the rtcwake command right now.

If the issue is common to both closed source and open source operating systems, it would have to be a BIOS/UEFI/firmware and/or hardware issue, not an OS issue as Intel is claiming.

 

0 Kudos
Time229
Novice
2,722 Views

Madbrain,

     You are right that this problem is "common to a number of Intel chipsets, multiple brands of motherboards, and multiple versions of Windows".  Also, I've found that the error is actually a loss (or should I say gain) of about 37 seconds per hour that the system remains asleep.  Almost seems like just a register counting/dividing error since it is cumulative. 

     I thought of Linux also, but as I recall I found that the rtc wake command actually uses the bios alarm, which seems to be different than this wake alarm in the Intel PCHs used by Windows.  In bios, the actual wake time is stored in the registers, and when the RTC matches it the system then wakes up.  With this Intel wake alarm register in the PCH though, the time difference until the next wake event is stored in the registers, which then count down until reaching zero, causing the system to wake.

    I still believe that this problem lies with whatever change was made by Intel between the 200 and 300 series chipsets with the wakeup methodology and/or how Microsoft coded it.

madbrain
Novice
2,711 Views

Thanks for your response. Is there a corresponding device for the PCH Wake Alarm in Windows ? I looked at device manager and all I could find was the "ACPI Wake Alarm" device. This device couldn't be disabled, in any case.

I don't see the same 37 seconds/hour that you observed. I see an approximately 10 minute delay in a 24 hour period. I deduce this based on my Acronis backups waking up the PC at 2am and the creation date of the backup file being 2:10am on the NAS (which is itself awaken by a WOL script). That corresponds to 25 seconds per hour. It does seem to be proportional to the time since last wake, though. I updated the BIOS for both my Z690 and Z790 systems, at a few hours interval. One machine had the next day's backup 10 minutes late, and the the other (which I had updated a bit later) just 8 minutes.

Re: Linux, I will report soon what my finding is. I wonder why Microsoft would opt to use a different approach if the previous one was working. Clearly that approach wasn't properly tested.

How far did you go with Microsoft ? Is there a public thread on their forums to join ?

 

0 Kudos
Time229
Novice
2,676 Views

The corresponding device/driver does indeed seem to be that "ACPI Wake Alarm" in the device manager.  I tested boards from several manufacturers with 300, 500, 600 and 700 series chipsets, they all exhibited this problem and they all had the "ACPI Wake Alarm" device.  In contrast, the 200 series board I tested along with all of my previous X99 systems did not exhibit this problem and they did not have the "ACPI Wake Alarm" device.

 

How I arrived at the figure of 37 seconds was as follows: I would create a wake event using Windows task scheduler for some interval in the future, such as 6, 12, 24 hours from (now).  I then put the board to sleep and waited for it to wake, getting the actual wake time from Windows event viewer (power troubleshooter).  Sometimes something unknown would wake the board up before the target event and I'd have to start over again.

 

Are you sure your system is actually continuously asleep for the full 24 hours?  You can view all the exact sleep and wake times as above- open Event Viewer and select Windows Logs->System in the left pane.  Then select 'Filter Current Log' in the right pane and in the box that opens go to the drop down 'Event Source' and select Power-Troubleshooter.

 

I tried a chat with a Microsoft representative, can't remember exactly how I got there now.  Mostly got "contact the motherboard manufacturer", even thought I explained at least three different brands had the same problem. Mentioned the ACPI Wake Alarm Device Driver- response was "What do you mean, Windows doesn't have any drivers".  Figured then about time to end this chat!

I do believe there are several Microsoft forums/boards though, not sure which would be best.

madbrain
Novice
2,670 Views

Thank you very much, this is very helpful, though it is not good news.

 

1. Thanks. I see that ACPI Wake Alarm device on both my Z690 and Z790 systems. I don't see it on the AMD X570 system I'm typing this on right now. I wonder if there is a way to forcibly disable the device on the Intel systems and make Windows use an alternative method for the wake timers. Sadly, this can't be done through device manager.

2. Re: 37 seconds, I definitely arrived at a lower (different) number. But I didn't try the power troubleshooter. I can certainly do so.

3. Yes, at least one of my PCs , the Z690 one, gets very little use and pretty much is asleep all the time except for the daily backup (used to be at night at 2am, I changed it do daytime at noon recently) except on the rare days I use it.  I also use smokeping which can show me when the system is pingable, so I know when it's off the network, which coincides with the time it's sleeping.  This PC consistently shows a 10 minute delay in the backup, based on the creation time of the Acronis 2019 TIB file.

4. Sounds like you got the wrong Microsoft rep ! Windows sure includes plenty of drivers ! If you haven't tried any MS forums, perhaps writing a thread there might get the attention of someone more competent. I'm willing to do that but not sure which forum would be best.

 

0 Kudos
Time229
Novice
2,656 Views

I don't know why they had to change this either (if it ain't broke...).  I actually used IDA to disassemble that driver, but honestly couldn't make heads nor tails of the result- too many relative [to what?] jumps and register addresses.  Also found the detailed description of the alarm register and its functions in the Intel PCH data book, but there again not knowing where the value is coming from nor how to access it externally didn't really help either.

I'm pretty sure I actually tried manually removing that driver once (from outside of Windows) just to see what would happen.  As I recall, the system just wouldn't wake for any scheduled events anymore, so another good indication that this ACPI Wake Alarm is indeed the culprit.  Would certainly be nice though like you said if there were a way to revert to the previous method they used.

 

Things have just gotten so complex over the years.  When I was at Tech school the Intel 8085 was the big thing (40 pin DIP IC). We actually had to build a small working system with a hex keypad and LED display. Can you imagine even attempting that now, what with CPUs having 1000 - 2000 pins!

0 Kudos
madbrain
Novice
2,655 Views

1. Wow, you went to great lengths. It's been a while since I disassembled x86 code and modified it. My first CPU was an 8086 in 1987. As a teen, I used to write TSRs that patched game code in memory to do various things that were unexpected - I'll leave it at that :). When Turbo debugger 386 later came along, it was a godsend as most DOS programs couldn't defend against this debugger.

2. Sorry to hear that removing the driver didn't have the expected effect.

3. I agree, most tech stacks are way too big and too complex nowadays.  Things were a lot simpler in the 80s and 90s.

 

0 Kudos
Reply