Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
1,332 Views

Can´t uninstall intel TBM 3.0 on W10 plz help

Hi

A couple of days ago I bought i9-7920X and have it on a Asus Rog Strix X299 E-Gaming board. Belong to the downloadsection of this board was the intel turbo boost manager 3.0.

Since I have installed it on my windows 10 64bit...

EDIT: Ihave a driver issue showing on the device manager "The device can't be started" (Code 10).

The TBM driver version I have installed is 1.0.0.1033 from 26.07.2017.

Bios vers is 0802

So I attempted to uninstall it by using Windows Control Panel, Programs, Uninstall a Program. If I do this it appears a dos window for a very short time and after this the advice to reboot the system.

After the reboot intel turbo boost manager 3.0 is still there. So I tried to disable it first on the device manager. This will function but I'm not able to uninstall intel turbo boost manager 3.0 anyway.

EDIT: As in this post already: /message/488439# 488439 https://communities.intel.com/message/488439# 488439

I have just a "Turbo Mode" option in the bios. And this option is disabled..

So I can't find proper help in this forum and the support site of Intel about my problem.

Before I start to do something inside the registry, I like to ask for help.

Thanks in advanced.

PS: Excuse my bad english

0 Kudos
5 Replies
Highlighted
Community Manager
56 Views

Hello Kamaling,

 

 

Thank you for contacting Intel® technical support. I will be more than happy to help you.

 

 

I understand that you are having issues with Intel® TBM in Windows® 10.

 

 

I see that you have already tried pretty much everything there is to try. One other troubleshooting that you can do is to install Intel® TBM again, just to try to overwrite the current installation, reboot the system, and try to uninstall it afterwards. This might help in some case.

 

 

Regards,

 

 

Xavier A.
0 Kudos
Highlighted
Beginner
56 Views

Hi Xavier A.

Thank you for your help.

Inside the 1.0.0.1033_64bit_20170920 zipfile are 3 exe:

- AsusSetup.exe

- AsusSetup64.exe

- ITBM.exe

I tried already to install ITBM again first just only with the AsusSetup64.exe and restarted the sytem after the message "Install finished".

It doesen't change anything.

So I tried also the AsusSetup.exe with no change in the result too.

Also I tried to start the ITBM.exe. If I do so, I recieve the errormessage: "ITBM Driver Not Available Exiting application"

I also tried to remove ITBM over the registry. Some entrys I was able to delete but if I like to delete the main keys there I recieve the errormessage that it is protectet und I doesen't have the right for this action.

I can not change the full access rights because of the same missing access of the admin status.

Of course I'm logged in as administrator.

Next problem is, that I did a safety copy befor I edited the registry, but if I like now to restore it, I recieve the errormessage: "Error xxx.reg can not be imported: Error by Access to the registry" (This message I translated free).

I'm sure this error happen about the access problem of the ITBM entry.

It seems that ITBM has bunkered itself properly.

So you see, there is a lot of complication about that all.

I hope we are able to find a solution.

0 Kudos
Highlighted
Community Manager
56 Views

Hello Kamaling,

 

 

Thank you for the information. We actually do not recommend to modify the Windows® Registry since this may cause inconveniences.

 

 

You can try installing the generic driver provided by Intel® to see if this works, and to see if you are able to uninstall it afterwards. Before installing the driver from Intel®, please check if Intel® TBM is enabled in your BIOS.

 

 

You can download the driver from the link below. Please keep in mind that you need to execute the file called ITBM.exe

 

 

https://downloadcenter.intel.com/download/26103/

 

 

Regards,

 

 

Xavier A.
0 Kudos
Highlighted
Beginner
56 Views

Hello Xavier A.

Thank you for your response.

I found the solution for my case.

After a bios update I deaktivated "Turbo Boost" there because I thought that my processor are good enough and don't need this additional overclock.

And so I installed windows 10 64bit after deaktivating Turbo Boost. This causes that ITBM will never more work properly. Any attempt to fix this by activating Turbo Boost after installing Windows or whatever I done with driver installation / deinstallation was not function.

Turbo Boost must be set on in bios before installing windows.

I set Turbo Boost on and installed Windows again. No problem since then. Eveything works fine now.

So for me this is solved and I hope that maybe it will help others.

Thank you for your help!

Best regards

Kamaling

0 Kudos
Highlighted
Community Manager
56 Views

Hello Kamaling,

 

 

I am very glad to know that you found the solution for the issue.

 

 

Thank you for sharing how the issue was resolved.

 

 

Regards,

 

 

Xavier A.
0 Kudos