Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Cybot
Beginner
924 Views

Intel Computing Improvement program .net framework error on load, "File Format is not valid"

Jump to solution

I have been receiving an error from the 'Intel Computing Improvement Program" whenever i try and load the program from the control panel, when the program is installed by the intel DSA, or when it is first loaded by the setup proram for the application.  I have included a copy of the error message contents below.  I can't figure out the cause of the error. It does not seem to be an issue with .NET. I have tried uninstalling the software, and reinstalling it, but the error persists, which makes me think it may be an issue with the software, not my system. The error seems to be similar to the issues described at the following link, which reinforces me belief that the issue is with the intel CIP program, not my system or user error.

https://help.citavi.com/en/knowledge-base/article/error-file-format-is-not-valid

I tried the solution to the error listed on the page but have yet to restart my system (windows update wants to install w10 20h2 update, which will take a while). will post back once windows is restarted (and updated to 20h2) to post if the error is still present

 

 

error message details:

 

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.ArgumentException: File format is not valid.
at System.Windows.Forms.RichTextBox.StreamIn(Stream data, Int32 flags)
at System.Windows.Forms.RichTextBox.StreamIn(String str, Int32 flags)
at System.Windows.Forms.RichTextBox.set_Rtf(String value)
at System.Windows.Forms.RichTextBox.OnHandleCreated(EventArgs e)
at System.Windows.Forms.Control.WmCreate(Message& m)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.RichTextBox.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
Assembly Version: 4.0.0.0
Win32 Version: 4.8.4220.0 built by: NET48REL1LAST_C
CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v4.0.30319/mscorlib.dll
----------------------------------------
SurConsent
Assembly Version: 2.4.0.5982
Win32 Version: 2.4.0.05982
CodeBase: file:///C:/Program%20Files/Intel/SUR/ICIP/SurConsent.exe
----------------------------------------
System.Windows.Forms
Assembly Version: 4.0.0.0
Win32 Version: 4.8.4200.0 built by: NET48REL1LAST_C
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System
Assembly Version: 4.0.0.0
Win32 Version: 4.8.4200.0 built by: NET48REL1LAST_C
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Drawing
Assembly Version: 4.0.0.0
Win32 Version: 4.8.4084.0 built by: NET48REL1
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
Config
Assembly Version: 2.4.0.5982
Win32 Version:
CodeBase: file:///C:/Program%20Files/Intel/SUR/ICIP/Config.DLL
----------------------------------------
System.Core
Assembly Version: 4.0.0.0
Win32 Version: 4.8.4220.0 built by: NET48REL1LAST_C
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
----------------------------------------
System.Configuration
Assembly Version: 4.0.0.0
Win32 Version: 4.8.4190.0 built by: NET48REL1LAST_B
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
System.Xml
Assembly Version: 4.0.0.0
Win32 Version: 4.8.4084.0 built by: NET48REL1
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
<system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

 

Labels (1)
0 Kudos
1 Solution
Cybot
Beginner
898 Views

looks like following the solution in link i found worked. hopefully, M$ will solve the incompatibility with the windows forms RichTextbox control sooner rather than later.

in case the link I posted goes dead, here is the solution from the page.

 

 The following solution is a workaround until Microsoft fixes the issue with an update. 

To perform the following steps, you need to have administrator rights on your computer.

  1. Close all open documents and programs on your computer.
  2. Press the Windows key.
  3. Type Settings
  4. Select Time & Language
  5. Click Language.
  6. Under Related settings, click Administrative language settings
  7. On the Region window, click the Administrative tab.
  8. Click Change system locale. Here you will need administrator rights.
  9. Clear the Beta: Use Unicode UTF-8 for worldwide language support checkbox. 
  10. Click OK.
  11. Restart your computer.

View solution in original post

2 Replies
Cybot
Beginner
899 Views

looks like following the solution in link i found worked. hopefully, M$ will solve the incompatibility with the windows forms RichTextbox control sooner rather than later.

in case the link I posted goes dead, here is the solution from the page.

 

 The following solution is a workaround until Microsoft fixes the issue with an update. 

To perform the following steps, you need to have administrator rights on your computer.

  1. Close all open documents and programs on your computer.
  2. Press the Windows key.
  3. Type Settings
  4. Select Time & Language
  5. Click Language.
  6. Under Related settings, click Administrative language settings
  7. On the Region window, click the Administrative tab.
  8. Click Change system locale. Here you will need administrator rights.
  9. Clear the Beta: Use Unicode UTF-8 for worldwide language support checkbox. 
  10. Click OK.
  11. Restart your computer.

View solution in original post

n_scott_pearson
Super User Retired Employee
911 Views

The solution is to go into Apps and Features and uninstall the Home Improvement package. You don't need it.

...S

Reply