Processors
Intel® Processors, Tools, and Utilities
14970 Discussions

Turbo Boost Window @ Startup

JJosh4
Beginner
11,021 Views

Just a quick question about Turbo Boost. Wasn't sure whether to ask in software or processor. Sorry if I chose poorly.

At startup "Intel Turbo Boost Max Technology 3.0" is always up on the screen. Just a minor annoyance, but is there a way to hide the UI at startup? I can't find the option.

If not, can I disable it at startup without losing the functionality? I found several posts about disabling the 'monitoring' window, but I'm not sure that's what this is.

Thanks in advance

18 Replies
idata
Employee
7,754 Views

Hello Aviem:

 

 

I looked for a possible work around in order to try to remove the tool from Windows start up, not sure if you already try this option but I found a link that might be useful for you:

 

 

http://www.howtogeek.com/74523/how-to-disable-startup-programs-in-windows/ http://www.howtogeek.com/74523/how-to-disable-startup-programs-in-windows/

 

 

Also, in regard to your question, if you disable the monitoring window the turbo boost will still work as it should, because the functionality of the feature does not depend on that program, it is just for you to be able to check how the turbo boost behaves.

 

 

If after trying the steps above the problem remains you can also get in contact with Microsoft for further assistance, they might have different options to resolve this situation.

 

 

Microsoft's support site: https://support.microsoft.com/en-gb https://support.microsoft.com/en-gb

 

 

Microsoft's phone number: 1 800-642-7676

 

 

Any questions, please let me know.

 

 

Alberto

 

0 Kudos
idata
Employee
7,754 Views

Hello Aviem:

 

 

I just wanted to check if the information posted above was useful for you and if the problem got fixed or if it still remains?

 

 

Any questions, please let me know.

 

 

Regards

 

 

Alberto

 

0 Kudos
MDäde
Beginner
7,754 Views

Hello, I had the same issue since I was using windows 10 (/thread/109932 https://communities.intel.com/thread/109932). It was solved for me after installing Intel Turbo-Boost Max Technologie 3.0 eng 1001031 this summer. But since the Windows Fall Creators Update I had the same Issue agin. The window poped up every startup. I installed intel(r) turbo boost max 1.0.0.1033 on 27. October with no success.

btw: The workarround from above is not working anymore. Under msconfig is "Systemstart" not configurable anymore, but you have to look in the Task-Manager. In the Task-Manger under Autostart is the Turbo Boost Window not listed for me.

Picture:

Today I noticed that it was popping up on startup, then disappearing like it should but popping up again. So I tryed to deinstall it. Did the deinstall, reboot -> BUT! It is now working.

It is still listed as installed with the date from today Picture:

And it is now minimized after startup.

Very strange.

0 Kudos
idata
Employee
7,754 Views

Hi AndroDawton: In order to try to fix this issue, you can either un-install the application, the Intel® Turbo Boost feature does not depend on the application so it will still work properly, or since the problem started after doing the Windows Fall Creators Update, the other option will be to get in contact with Microsoft directly in order to get a possible solution or a workaround for this problem:

https://support.microsoft.com/en-us/contactus/ https://support.microsoft.com/en-us/contactus/

Regards,

 

Alberto R
0 Kudos
MDäde
Beginner
7,754 Views

Thx, but i cant deinstall the "application" UI. It is after the reboot still listed as installed.

0 Kudos
n_scott_pearson
Super User
7,754 Views

Are you using the Apps and Features scene to uninstall it? Is the uninstall proceeding to completion without error? Did it ask you to do the reboot or did you just do so on your own initiative?

0 Kudos
MWolf11
Beginner
7,754 Views

Try this:

- Open computer management (for instance right click the "^This PC" icon, select (more) > "Manage"

- On the left hand side drill down the tree Computer Management > System Tools > Task Scheduler > Task Scheduler Library

- Now you have all scheduled tasks listed in the top center part of the screen, look for Intel(R) Turbo Boost Max 3.0 Technology Application Launcher

- Right click that entry and select "Disable"

After the next reboot the application shouldn't start automatically anymore

0 Kudos
MDäde
Beginner
7,754 Views

>Are you using the Apps and Features scene to uninstall it?

Yes

>Is the uninstall proceeding to completion without error?

Yes

>Did it ask you to do the reboot or did you just do so on your own initiative?

As far as I remember it is just "uninstalled". I did the reboot by my own. I got a promt to reboot after the deinstall, which I did. After the reboot the entry is back in the Apps and Features scene.

0 Kudos
MDäde
Beginner
7,754 Views

Changing or even deleting the entry is not possible.

After the reboot the entry is like this again:

https://imgur.com/J84rKE5 View post on imgur.com
0 Kudos
JSach2
Beginner
7,754 Views

I was able to get this to run minimized.

Everything else I have tried has failed so this may be the only way to have this run, but not be up in your face when starting Windows.

Just go to C:\Program Files (x86)\Intel Corporation\Intel(R) Turbo Boost Max Technology 3.0\

Rename ITBM.exe to whatever.exe. Upon startup, the program runs but does not come to the foreground, which is a desired result.

Also, this was done in tandem with disabling the ITBM service under Services in Device Manager.

I think it's irresponsible of Intel to point fingers at Microsoft and put the burden of this poorly written program onto thousands if not millions of users. How hard would it be for the program writers to put a checkbox that minimizes this application on startup. Shame on you intel.

0 Kudos
THubb
Beginner
7,754 Views

I'm having the exact same problem.

Tried to uninstall the program through add/remove programs, and it prompts me to restart.

So I click restart the computer.

Computer restarts and it still pops up. Repeatedly I have tried this process.

AND repeatedly tried various methods to disable it from running at start up.

But no matter what I try or do, this annoying little window keeps popping up everytime I restart.

This is getting annoying to say the least.

0 Kudos
THubb
Beginner
7,754 Views

After messing around in the registry with no success...Went simple.

Not a fix, but it stops the program from running.

Go to the directory that the intel boost executable file is located (C:\Program Files (x86)\Intel Corporation\Intel(R) Turbo Boost Max Technology 3.0)

First make sure that you quit the program so it's not running

Rename the "ITBM.exe" file to whatever (I just renamed it to ITBM.exe.bak)

That's it, next time you restart the file is still renamed and doesn't execute.

No more pop up window!

0 Kudos
MW2
Beginner
7,754 Views

That tool is started by a scheduled task, that you can't delete because it will be recreated automatically by a service.

Solution:

1. Close the tool by right clicking it in the tray and "Quit".

2. Press [Win]+[R] and run "services.msc".

3. Search for the service "ITBMService" or the descriptive name "Intel(R) Turbo Boost Max 3.0 Technology Application Service" and disable that service.

4. Press [Win]+[R] and run "taskschd.msc".

5. Search for the task "Intel(R) Turbo Boost Max 3.0 Technology Application Launcher" and disable or delete that task.

6. Reboot your system

Now that tool shouldn't be started automatically anymore

JTied
Beginner
7,754 Views

Thank you. This worked for me.

In step 5, look for Intel Turbo Boost Max 3.0 Technology at the Task Scheduler Library level. It doesn't show up in the Intel folder.

After disabling this startup behavior, you can still run ITMB anytime you want (not that I use it). It should be in your Start menu.

0 Kudos
JTied
Beginner
7,754 Views

Well, except there's a minor hitch.

Don't run the Intel Turbo Boost Max 3.0 Technology app, as apparently it re-enables the startup task.

0 Kudos
JTied
Beginner
7,754 Views

Sorry, I have to completely reverse myself here. ITBM just came up again on startup. Apparently there's something else besides or in addition to the ITBM app that re-enables the startup task.

0 Kudos
JTied
Beginner
7,754 Views

Here's what's working for me at the moment. I downloaded the latest version of the ITBM driver.

There's a post above about installing version 1.0.0.1033, which, I can't tell from the post whether that worked. But the current version is 1.1.0.1005. My impression so far is that they've changed the functionality so the UI doesn't open on startup. I've done a couple restarts.

(Go to Intel, Support, Downloads & Drivers, Browse for Drivers, search on "Turbo Boost Max Technology.")

0 Kudos
JElli10
Beginner
7,754 Views

Aviem

Have you tried to right-click on the icon in the taskbar?

Once, you right-click on the icon there should be a pop-up menu that has 5 Options.

Option 1: Enable

Option 2: Disable

Option 3: Show UI or Hide UI*

Option 4: About

Option 5: Quit

Now Option 3 can change from "Show UI" or "Hide UI" depending on wither or not you have clicked on it before. Now, if it shows Hide UI click on that and it will Minimize to the Icon Tray and stay there till you either Double-Click on it or Right-Click and click on "Show UI".

Once, you have clicked on "Hide UI" ITBM will only show for a moment or two when you start-up your system and then it will minimize to the icon tray.

I have run into it staying on-screen until i figured out that clicking on the Hide-UI option. Once, i did that everytime i start or restart system the program ITBM pops on the screen for a moment then minimizes to the icon tray.

Uninstalling and Reinstalling the program will not solve your problem as mentioned in other posts. Only Option # 3 or not installing the program at all will work.

0 Kudos
Reply