Programmable Devices
CPLDs, FPGAs, SoC FPGAs, Configuration, and Transceivers
Announcements
The Intel sign-in experience is changing in February to support enhanced security controls. If you sign in, click here for more information.
19679 Discussions

USB Blaster driver problem

Altera_Forum
Honored Contributor II
1,944 Views

I just downloaded Quartus II yesterday to a new machine (I've been using it at a different location before). Quartus runs fine and I finished my first design with it just now and I'm ready to try burning the 3128. I also bought a new USB Blaster (rev C) to go with the new setup.  

 

Installing the USB driver failed. I followed the instructions and pointed the Add Hardware wizard at usbblstr.inf where the Quartus installer put it. However, I get the message "The specified location does not contain information about your hardware" OK .. like that's really OK? 

 

I presume the inf file is somehow hosed. I went to the Altera website, but I can't find that file. In fact, I can't find ANY driver for the USB Blaster. 

 

I'm dead in the water. 

 

To make matters worse, there seems to be no way to get email help from Altera. The stupid "myAltera" support really sucks big time. Lots of circular links giving zero help. Altera used to be a great support company. I guess that's no longer the case. 

 

OS is XP home. The machine is a 1.7G CPU with lots of RAM .. I can't see how that would be a problem. 

 

Any ideas welcome. 

 

Thanks .. Alan
0 Kudos
6 Replies
Altera_Forum
Honored Contributor II
470 Views

1 - What other USB devices do you have connected to the computer? The USB-Blaster uses the FTDI usb chip set. There have been problems in the past when some other device is connected to the PC that uses the same chipset. 

 

2 - One way to get the driver is to download the standalone programmer: 

https://www.altera.com/support/software/download/programming/quartus2/dnl-quartus2_programmer.jsp 

 

3 - You pointed the driver wizard to this location:? 

C:\altera\91\quartus\drivers\usb-blaster 

 

4 - Did you try the USB-Blaster cable on another PC just to verify it? 

 

Jake
Altera_Forum
Honored Contributor II
470 Views

Thanks for the note! 

 

Yes, there is another USB port in action. I will try to disconnect that and see if it helps. However, the problem seems to be in finding the inf file or the file itself is hosed.  

 

Plugging in the USB Blaster pod brings up the "new hardware" window, so it seems to be functional. 

 

I installed Quartus on my F: drive. I'm wondering if that is why it can't find anything. My C: drive is small, so I prefer to load software elsewhere. 

 

I found a copy of the driver on my laptop where I also have Quartus running OK. The Blaster works OK there. I will try to copy this driver file (and the SYS files) when I get back. I saw that download link, but thought it was for a different stand alone programmer. It says nothing about using it for the USB Blaster.
Altera_Forum
Honored Contributor II
470 Views

Hi everyone. 

I have the same problem with the usb-blaster XP driver installation.  

I received the same answer "The specified location..." .  

I tried to install the driver in another computer with different usb_blaster, and received the same answer.  

Yes, I have the ftdi driver chipset installed in my computer. trying to uninstall the driver didn't solve the problem. 

 

what else can i do ??? 

 

(O.S Windows XP SP2, Quartus II 9.1)
Altera_Forum
Honored Contributor II
470 Views

I got zero help from Altera, but I eventually solved this problem by NOT following the Altera solution. 

 

Plug in the USB Blaster and wait for the "Found New Hardware" wizard to start. Instead of closing that and going down the manual install path as Altera suggests, play by the Microsoft game rules. The wizard worked for me once I pointed to where the driver files were located. Doing that with the manual installation procedure failed. That may be because I am installing in my F: drive instead of the more standard C: drive. 

 

GL!
Altera_Forum
Honored Contributor II
470 Views

Thank you very mach ad6e, you were right, I got luck and it solve my problem.

Sudhamshu_B_N
Novice
306 Views
Reply