Programmable Devices
CPLDs, FPGAs, SoC FPGAs, Configuration, and Transceivers
20867 Discussions

cannot program my apollo agilex SOM board

Ourspalois
Beginner
772 Views

Hi,

I am trying to program an apollo agilex board.

In doing so I have the problem of setting the VID assigments of the card.

(I could not find any documentation from terasic on the correct VID settings so I had to find them in examples projects, so I am not a 100% sure they are right)

so here are my settings :

```

set_global_assignment -name USE_PWRMGT_SDA "SDM_IO0"
set_global_assignment -name USE_PWRMGT_SCL "SDM_IO12"
set_global_assignment -name PWRMGT_SLAVE_DEVICE_TYPE "Other"
set_global_assignment -name PWRMGT_SLAVE_DEVICE0_ADDRESS "4F"
set_global_assignment -name VID_OPERATION_MODE "PMBUS MASTER"
set_global_assignment -name PWRMGT_BUS_SPEED_MODE "400 KHZ"
set_global_assignment -name PWRMGT_VOLTAGE_OUTPUT_FORMAT "LINEAR FORMAT"
set_global_assignment -name PWRMGT_LINEAR_FORMAT_N "-12"
set_global_assignment -name PWRMGT_TRANSLATED_VOLTAGE_VALUE_UNIT "VOLTS"
set_global_assignment -name PWRMGT_PAGE_COMMAND_ENABLE "ON"
set_global_assignment -name PWRMGT_PAGE_COMMAND_PAYLOAD "255"

```

they all seem to be legal, but running my quartus synthesys I get these errors :

```

quartus_syn integnano_pinaipple_pinaipple_system_0
Error (22819): The option assigned for assignment (USE_PWRMGT_SDA : SDM_IO0) is not supported.
Error (22819): The option assigned for assignment (USE_PWRMGT_SCL : SDM_IO12) is not supported.

```

This is weird to me since I am running quartus prime pro 22.4.0 (which is not that old) and the configuration page for agilex says thoses SDA and SCL configs are allowed :

https://www.intel.com/content/www/us/en/docs/programmable/683373/current/configuration-pin-parameters.html

I will try installing quartus 23.1 to solve this issue.

Is there something I am doing wrong here ?

Many thanks

0 Kudos
1 Solution
WZ2
Employee
716 Views

Hi there,

Your setting of "SCL" and "SDA" seems be reversed. SCL for IO0 and SDA for IO12~


View solution in original post

4 Replies
WZ2
Employee
717 Views

Hi there,

Your setting of "SCL" and "SDA" seems be reversed. SCL for IO0 and SDA for IO12~


WZ2
Employee
698 Views

Hi there,

Is it solved~


0 Kudos
Ourspalois
Beginner
679 Views

Hi,

I was indeed too tired to notice ^^'

sorry for the useless thread and thanks you for the response.

0 Kudos
WZ2
Employee
678 Views

Hi there,

I wanted to check if you have any further questions or concerns. If not, I will go ahead and mark this issue as resolved.

Additionally, we would greatly appreciate it if you could take a moment to fill out our survey. Your feedback is valuable to us and helps us improve our support quality.

Thank you for your time and cooperation.

Best regards,

WZ


0 Kudos
Reply