Rapid Storage Technology
Intel® RST, RAID
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!

ISRT/AHCI Issue

011
Beginner
466 Views

Hi, so I was searching for other posts relating to my issue and I see some but there are a few minor differences and because of the possibility of losing all my data I wanted to make a new post.
    To start I bought a Samsung 960 EVO M2 NvME SSD to add to my PC. I currently use a 256GB PNY M2 SSD as my boot drive and a 1TB WD Blue HDD as storage. Well my motherboard (ASUS Maximus Hero IX) has two M2 slots. Whenever I plug this new ssd in I get stuck on the ASUS Splash screen. Cant boot into bios or windows, nothing. I swapped around the drives in all ways and found that the M2 ports on the board must be in working order because the PNY will boot from either. So I'm about to call the 960 a dead SSD when I notice in my BIOS that i have IRST turned on. I have never even tried to setup a RAID solution nor do i really know how it works. Before posting this I downloaded Intel rapid storage GUI and it does show the PNY and WD. Does that mean they're running in a RAID option?
       I tried turning off IRST in my bios and it would go into a boot loop without ever letting me into windows but I could get back into the bios with the PNY SSD just no further then the bios. I could not do anything with the 960 SSD. The second I turn it back on though everything seems fine and I can do as i please. I tried clearing CMOS several times, turning off XMP, removing overclock etc... I read someone else that was having this same issue and their instructions were to reinstall windows. So if I do need to do that can I do it in the normal way with media creation tool or putting it on a USB as an ISO or are there special steps I need to take? Also, would it be better for me to run these three drives as a RAID setup? I'm willing to give that a go. All I do with my PC is gaming and some digital art. Full specs ill post below. Thanks for any help. Here are some screenshots that may help identify the issue. The first three are of RST GUI and the last one is of my BIOS and the settings that are set. evBAYg1.pngeM6spLO.pngswupdMN.pngJ4P9fxL.png

Intel I7-7700 (non k)
MSI RTX 2070 Super
Cooler Master ML240 AIO
16 GB 3200 DDR4 OlOy Ram
256GB PNY CS3030 M2 SSD
1TB WD Blue 7200 HDD
Asus ROG Strix Maximus Hero IX Motherboard
Cougar CMX700 650w PSU 80+ Bronze

0 Kudos
6 Replies
n_scott_pearson
Super User Retired Employee
449 Views

According to the datasheet for your mobo, you should be able to use NVMe SSDs in both of the M.2 sockets. I do not see any reason other than a bad drive for the system hanging. Bad drives do happen, unfortunately.

I personally am not a fan of the use of RAID0 with two NVMe SSDs. The speedup will be smaller that you might expect, due to the limitations of the DMI bus that connects the CPU and PCH (chipset). There are a couple of write-ups on this floating around on the web if you are interested in details (or I can answer this separately). Using RAID1, on the other hand, is more reasonable; the cost of keeping the backup is smaller that it might be otherwise.

If you are going to use RST for RAID, then you are ok with the Windows install that you have. If you are not going to use RST, I recommend that you disable it in BIOS Setup. There is supposed to be a way to fix the existing Windows installation so that a reinstall is not necessary, but I am unsure of the process (@LeonWaksman, do you know?).

Hope this helps,

...S

LeonWaksman
Super User
441 Views

Hi @011  (and Scott),

I've changed the SATA mode from Intel RST Premium with Optane to AHCI few times, without need to reinstall the Windows (it should be done in SAFE boot mode). I did this on NUC computers, but the same method should be good for your board. As always, before performing such procedure, I recommend to prepare full backup image of your system in case that something goes wrong. Follow those instructions, to change SATA mode from "Intel RST..." to AHCI:

  1. While in Windows, press Windows key + r. Run msconfig
  2. Chose Boot tab and enable Safe boot. Reboot your system. 
  3. During system boot enter Bios . Now you can change the SATA mode to ACHI. Save the setting and boot into windows in SAFE mode. Disregard any warnigs.
  4. While in Windows, press Windows key + r. Run msconfig
  5. Chose Boot tab and uncheck Safe boot. Reboot your system. 
  6. Now your system is bootable in ACHI mode .
  7. Uninstall the RST software. You don't need this anymore.

  However, I don't understand how installing empty SSD in either M.2 slot prevents boot to Windows. Could be that the new SSD is failed and doesn't pass POST. So, if after changing the SATA mode to AHCI you have still this problem, I suggest to test this SSD:

1. Remove the 256GB PNY CS3030 M2 SSD and the 1TB WD Blue 7200 HDD.

2. Install the Samsung 960 EVO 

3. Prepare Windows 10 installation USB and try to install Window on SAMSUNG SSD.

Leon

 

011
Beginner
439 Views

Great thank you guys, thats exactly what I was looking for. I'm with ya on the SSD boot issue. I would think if i was booting from one SSD then installed a second, bad, SSD (non boot), I would still be able to boot but i would get errors for the second ssd slot or it just wouldnt show up. But hopefully this is the issue. I'm goinng to make the backup now and see what happens. Thank you guys!

Oh and i tried reddit and a few other hardware forums, not a lot of people have knowledge with IRST. It's a relief finding some experienced words. Thanks again

1

n_scott_pearson
Super User Retired Employee
426 Views

Well, I have certainly seen cases before where a bad SSD hangs the system. Remember that this is a device that is communicating via 4 PCIe Lanes. Failures at this level will have an overall negative effect on system operation.

...S

011
Beginner
420 Views

So an update I was very easily able to boot into safe mode, switch to AHCI and then back to windows with no issues. Thank you! Is there anything else I should do besides uninstalling RST to optimize the non raid setup. Or is it good to go right after making those bios changes?
    As for the new SSD, it still decided not to work. So i feel comfortable with the amount of effort i put into trying to making it work, i'll just return the thing because i'm fresh out of ideas.
   Oh also I made a video of my post codes. I am assuming this is just cycling through the POST process and as each one completes it moves to a new code? Or it stopping momentarily on a code means its throwing said code? A0 is what the system always finishes on and boots just fine. 
ASUS Maximus Hero IX Post Code definitions 
Video post codes during boot 

LeonWaksman
Super User
402 Views

Hi @011 

1. As for the POST codes on the video you have attached, I'll not comment because I'm not familiar with this board.

2. Since when the new SSD is installed, you can't even boot into BIOS, it looks that the SSD is failed and and need to be replaced.  Since the currently installed SSD (PNY), is and NVMe SSD, means that the board should works with this type of SSD.

Leon

 

Reply