Rapid Storage Technology
Intel® RST, RAID
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!

Intel RST: BSOD & Slow Start

EMede
Beginner
1,458 Views

Hi,

I installed the latest version of the Intel RST driver (12.9.0.1001), but since I installed it I have been having problems with booting up and shutting down.

The symptoms are as follows:

  • When I boot for the first time, I often (but not always) get a BSOD with the message DRIVER_POWER_STATE_FAILURE
  • When I then reboot, it works but takes a very long time (2 mins 30 seconds, where it was under 1 min previously and under 30 secs originally)

The same issues apply when waking from S4 Hibernation. The laptop seems to work fine once it has booted.

I applied a trace on the boot using the Windows Performance Toolkit (xbootmgr -trace), and it shows a period of 2 minutes before the start of any hard drive activity. I have attributed this to an issue accessing the SSD following the installation of the iRST driver.

My hardware is as follows:

  • Laptop: Asus UX32VD
  • Intel Series 7 Chipset Family
  • SSD: Samsung 840 EVO (1gb)
  • SATA port set to AHCI mode in BIOS

I am happy to provide the .etl file showing the slow boot time (it is over 1gb so can't attach here, but I did attach the .xml summary). Unfortunately I don't get a dump from the BSOD, presumably because the issue is with the drive and the dump can't be written.

Thanks,

Elie

0 Kudos
1 Solution
Allan_J_Intel1
Employee
165 Views

Thanks for joining the community.

I am sorry to hear that have had issues with the latest Intel Rapid Storage version 12.9.

I would like to know if this issue used to happen with previous version, at this point, version 12.8

Please test an earlier version here:

https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&ProdId=2101&DwnldID=23060&ProductFamily=Soft... https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&ProdId=2101&DwnldID=23060&ProductFamily=Soft...

 

 

Allan.

 

View solution in original post

2 Replies
Allan_J_Intel1
Employee
166 Views

Thanks for joining the community.

I am sorry to hear that have had issues with the latest Intel Rapid Storage version 12.9.

I would like to know if this issue used to happen with previous version, at this point, version 12.8

Please test an earlier version here:

https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&ProdId=2101&DwnldID=23060&ProductFamily=Soft... https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&ProdId=2101&DwnldID=23060&ProductFamily=Soft...

 

 

Allan.

 

View solution in original post

EMede
Beginner
165 Views

Hi Allan,

Thanks for getting back - that seems to have resolved the issue.

I tried:

  • booting (still a 30sec inactivity period, but much better than 2 mins)
  • hibernating now works
  • restarting a few times - no BSOD so far

Thanks very much for the suggestion. I'll report back here if I notice any further problems, but based on brief testing I'm happy this is resolved.

Thanks!

Elie

Reply