Community
cancel
Showing results for 
Search instead for 
Did you mean: 
NShir1
Beginner
1,647 Views

Intel RST RAID shows in BIOS but not in Windows after Win10 reinstall

I've got a RAID 10 of four HDDs setup in my BIOS using Intel's RST system. I had Windows 10 installed on a 250GB SSD and reinstalled it on a 500GB SSD for more program space. After the reinstall, I can see the RAID is fine in the BIOS, but it isn't visible in file explorer. If I try to see them in Disk Management, it shows a Disk 1 and a Disk 2 (both "Dynamic") and it lists them as being "Foreign." If I look at them in Device manager I see the SSD plus two "Intel Raid 1 Volume" listings. So it's like Windows sees the mirrored RAIDs, but can't see them striped together?

I know the RAID is still fine because if I swap out my new windows install on the 500GB SSD for the old install on the 250GB SSD, windows still sees the RAID with all files intact.

 

I thought this might be a driver issue, but if I look at the Intel Chipset SATA RAID Controller in Device Manager, it shows the same driver version as in my old windows install (15.44.0.1010).

 

If I have to, I know I can backup the RAID and then rebuild it from scratch... but I'd like to avoid that...

 

Thanks in advance for any help!

0 Kudos
3 Replies
NShir1
Beginner
409 Views

Update:

 

So I installed the latest driver I could get from Intel (15.9....) and it didn't change anything. I then tried several different older drivers as I vaguely remember reading about conflicts between older hardware and newer intel drivers. Same outcome with everything I tried. Intel wouldn't let me install the latest driver (16.....) -- instead they have a new program you download and run (IDSA) which scans your system and tells you which driver to use. It scanned, saw my RAID, gave me the driver to install (14.8.16.1063) -- but I still have the exact same problem.

 

A couple things I learned along the way:

 

The two "drives" of my RAID I can see within Device Manager and Disk Management are separate partitions on the RAID 10 itself. So it seems as though Windows is seeing the RAID as a single drive after all, but in Drive Management it still labels each partition as "Foreign" with a little triangle (!) symbol.

 

Also, this Intel software I installed loads at Windows startup and shows me the RAID 10, with everything normal and working... but it still doesn't show in Explorer.

 

I feel like I must be missing something obvious, but I have no idea what it would be.

NShir1
Beginner
409 Views

Finally got it to work, and it was a ridiculously easy fix (after reading this https://www.easeus.com/partition-manager-software/what-is-foreign-dynamic-disk-and-how-to-fix-it.htm... ):

So in Disk Management, all I had to do was right click a "Foreign" disk, and tell it to "import foreign disks." Then voilà, there it was.

Alberto_R_Intel
Moderator
409 Views

NShir1, Thank you for posting in the Intel® Communities Support. Perfect, excellent, we are glad to hear that you were able to find the solution for this scenario, thank you for sharing those results. Any other inquiry, do not hesitate in contact us again. Regards, Alberto R. Intel Customer Support Technician Under Contract to Intel Corporation
Reply