Rapid Storage Technology
Intel® RST, RAID
2003 Discussions

Intel RST crashing under Server 2008 R2


I may as well add another to the pile...

I have an Asus P7P55D Deluxe that is running Server 2008 R2. It has 2 SATA controllers, one Jmicron that has just 1 drive connected (c:\) and an Intel RAID controller with 6 drives connected, configured in 3 pairs of 2 drives each (all as RAID1). I can see all the drives in Windows and read/write to them just fine. I believe the RAID controller has version 8.9? Also, the Jmicron controller is configured as AHCI.

I'm trying to get Intel RST 11.6 running and it's failing to start. The system tray icon says the service is not running and when I go to manually start the service, I get "Error 1067: The process terminated unexpectedly". I've seen lots of fixes referring to .NET 3.5.1, so I've tried installing .NET 3.5.1 features, then installing .NET 4 via Windows updates and then finally reinstalling RST, still getting the same error.

I had this working fine on Windows 7, but I may have had an older version of RST. Is there a fix/workaround for this version, or do I need to find an older version for it to work? I'd like to get in-OS RAID management and/or monitoring working...

0 Kudos
0 Replies