Rapid Storage Technology
Intel® RST, RAID
1847 Discussions

RAID initializing does not let Windows finish loading


When did Intel add the "initializing" step to raid building? I have used earlier versions of RST and it did not do this. After defining sets and volumes and formatting them, the job was done.

I am currently building a server with a RAID 10 array with (4) 1.5TB WD drives. I have created two volumes, a 200GB System drive and a 3.4TB Data drive. I installed Windows Server 2008 R2 on the System drive. Some time after that, "Initializing" began. Now, Windows cannot finish loading. It is stuck on the Windows logo screen with the scrolling barng.

As a result, I cannot see what is happening. I am quite sure it is initializing because of the constant disk access, but nothing else. I don't want to cut the power (YIKES), but without doing so, I cannot report what version of RST ROM I have or where the initializing stands.

It looks like others have not run into this specific problem. Any advice on what I should do? It has been at the logo for 3 hours now.

0 Kudos
2 Replies

After 7 hours the disk activity stopped, so I forced a power-off. During boot-up the RAID utility ( now showed "Normal" status instead of "Initialize". I thought I was all set! No such luck.

The Windows logo with the scrolling bar still stayed on the screen forever. After the first few seconds there is no disk activity at all. Have to power-off. Startup Repair finds the Server 2008 R2 installation, but it says the location is "unknown local disk" and does not even try to repair it. I tried all known command-line utilities in the Recovery Console for repairing boot sectors, boot records and BCD, nothing worked.

I decided to start over. I deleted the volumes, made all drives non-RAID, then recreated the RAID-10, 4-disk array with a 200GB System volume and a 2.5TB Data volume. Reinstalled W2K8R2 on the System volume. After the first reboot, the scrolling Windows logo hung again!! No disk activity. Tried several restarts, same thing. It offers startup repair, but still shows Unknown location and does not repair.

This was all working fine before the original Initializing Volume phase in my first post. Now I can't even recreate the array and successfully install Windows! I'm wondering where this failure is coming from . Controller went bad? This is a brand new Supermicro Q67-based motherboard.

Valued Contributor III

The initialization process has been established since older versions of Intel(R) Matrix Storage Technology. Probably this was not noticeable as before due to the much smaller sizes of the volumes back then.

This process is always performed when the operating system loads, which is when the RAID driver starts functioning (so this will not initialize during post or while sitting in the RAID Option ROM).

You may try updating the system BIOS in your system which should update the Option ROM in your system (or check with SuperMicro for an updated version) and create just the system volume to install the operating system and boot to it. After this is done, create the large data volume within the operating system through the Intel(R) Rapid Storage Technology user interface.