Community
cancel
Showing results for 
Search instead for 
Did you mean: 
mwhalenhtc
Beginner
63 Views

Repairing RST RAID boot

I use a bare-metal backup system and have recently restored a backup to my drive. The backup environment uses Ubuntu Linux and dd to restore the drive. To see the disks, the BIOS had to be set to AHCI/SATA mode. The restore was successful and the computer boots ... in AHCI/SATA mode.

While it's sort of irrelevant, I've got time to kill and would like to try to repair the install so that it can boot with the RAID BIOS setting. Doing that now results in the Inaccessible Boot Device BSOD. I've found a great many things to try, but nothing has worked. Installers say "unsupported platform." I _think_ I've found the right drivers since, if I load them during a Windows install, the installer can see the drive.

Can I repair this and how, if so?

Some details...

Dell Precision 3560 - 1TB NVMe/M.2
Windows 10 Pro

0 Kudos
2 Replies
mwhalenhtc
Beginner
40 Views

Here’s the solution for the Intel RAID boot

You’d boot into something that would get you to a command prompt. I used a Windows-installer prepared USB drive. On the same USB drive, I placed the driver, unzipped. This would be the same driver that you’d need for the Windows installer to see the internal storage. That needs to be found first. In my case it was, “https://downloadcenter.intel.com/downloads/eula/28997/Intel-Rapid-Storage-Technology-Intel-RST-User-...”. You can confirm this is the right driver by putting the BIOS in RAID mode and going through the install routine just far enough to have to load the driver. If you load the driver and the installer can see the internal storage, then you know you have the right driver.

I booted to the USB in AHCI mode. Once in there, I went to Repair your computer. At that point, I made sure I had access to the Windows partition (OS). In my case, it was C:

Then, I ran the command below:

Dism /Image:C: /Add-Driver /Driver:D:\f6flpy-x64\iaStor.inf

That altered the Windows partition and I could boot in RAID mode.

AndrewG_Intel
Moderator
31 Views

Hello mwhalenhtc

Thank you for posting on the Intel® communities.


We understand and we are glad to know that you were able to found a solution for the RAID boot issue. Thank you for taking the time to share this feedback, hopefully, it may help other community peers experiencing similar behavior.

Having said that, we will proceed to close this inquiry now. If you need any additional information, please submit a new question as this thread will no longer be monitored.


Best regards,

Andrew G.

Intel Customer Support Technician





Reply