Community
cancel
Showing results for 
Search instead for 
Did you mean: 
SBuch1
Beginner
1,658 Views

SATA RAID option - EFI

I am trying to setup a SuperMicro server to run a Centos 7 application as a network appliance where the end user will have not access to the server except through the applications interface. The server has a SuperMicro X10SRM-TF motherboard containing the Intel C612 chipset and is configured with 2 SSDs in a RAID-1 array. The server is running the current BIOS (2.0b).

With the Advanced - SATA Configuration - SATA RAID Option ROM/UEFI Driver setting in BIOS set to [Legacy] I can configure the RAID array using the Intel® Matrix Storage Manager user interface by hitting CTRL-i at boot time and everything works as expected. The problem is that we do not want the end user to be able to modify or delete the RAID configuration. I can remove the option for the user to access the Intel® Matrix Storage Manager user interface by changing the Advanced - SATA Configuration - SATA RAID Option ROM/UEFI Driver setting in BIOS set to [EFI] which removes the CTRL-i prompt at boot time and moves RAID configuration into the main BIOS menu. When I change the setting to EFI, BIOS no longer sees the RAID array and the RAID array is not available as a boot drive.

How can I make a RAID volume seen and bootable from BIOS with the Advanced - SATA Configuration - SATA RAID Option ROM/UEFI Driver setting in BIOS set to [EFI] ?

Thanks,

Steve

SATA Option ROM - 4.6.0.1018

Tags (1)
0 Kudos
1 Reply
idata
Community Manager
647 Views

Hello SteveBuch,

 

 

Thank you for contacting Intel Communities.

 

 

I understand you want to setup a bootable RAID volume from BIOS using a SuperMicro X10SRM-TF server board.

 

 

After checking the specifications, since this board has an Intel® Server Chipset C612, please bear in mind that this kind of issues is handled by the board's manufacturer.

 

 

https://www.supermicro.com/support/contact.cfm SuperMicro Support

 

 

I hope this information helps.

 

 

Best Regards,

 

Juan V.
Reply