Community
cancel
Showing results for 
Search instead for 
Did you mean: 
MBeck4
Beginner
7,784 Views

Uninstalling/reinstalling proper RST version

Hello all - I hope this is the right forum for my question. I am not an expert user.

I have a Dell Latitude E7440, running Windows 10 after recently updating from Windows 7. My basic system information is below.

Recently, after being prompted by a third-party software update utility (not Dell's driver update utility), I updated my Rapid Storage Technology package to the latest version (16.0.2.1086) directly from the Intel site (not through Dell).

I realized shortly thereafter that this was probably a mistake. The Dell site for my device specifically identifies an older version -- 14.8.1.1043,A14, which I believe is what I was running before -- as the right one for my somewhat older system. While I haven't noticed any obvious problems with my system yet, I'm concerned about instability or other potential issues.

I therefore attempted to reinstall the older driver directly from the Dell site, hoping that it would roll back the driver to the original version. The wizard reported a successful installation, but it did not appear to remove the new version from my system, and I don't see any evidence that the original driver is in use now. I've repeated that several times, always with the same result.

I then tried uninstalling Rapid Storage Technology 16.0.2.1086 directly, using the Programs/Features function, with the idea of trying to reinstall the old driver after uninstalling the new one. It stopped short of removing the driver, saying it was in use and that proceeding would risk destroying data on my SSD. It *did* remove the RST interface, so that it no longer shows up as an installed program.

Can anyone guide me as to how to proceed from here? I'm not sure whether the new driver is even functioning anymore, whether it is safe to stick with the newer version, or -- if I need to go back to the original RST 14.8.1.1043, A14 -- how to go about rolling it back.

Apologies for my lack of expertise, and thank you in advance!

-----------------------

# SSU Scan Information

Scan Info:

Version:"2.5.0.12"

Date:"05/03/2018"

Time:"00:00:16.0547260"

Computer:

BaseBoard Manufacturer:"Dell Inc."

BIOS Mode:"Legacy"

BIOS Version/Date:"Dell Inc. A25 , 02/01/2018 12:00 AM"

CD or DVD:"Not Available"

Embedded Controller Version:"255.255"

Platform Role:"Mobile"

Processor:"Intel(R) Core(TM) i7-4600U CPU @ 2.10GHz , GenuineIntel"

Secure Boot State:"Not Available"

SMBIOS Version:"2.7"

Sound Card:"Realtek High Definition Audio"

System Manufacturer:"Dell Inc."

System Model:"Latitude E7440"

System SKU:"05CB"

System Type:"x64-based PC"

- "Processor"

- "Intel(R) Core(TM) i7-4600U CPU @ 2.10GHz"

Architecture:"x64"

ATPO:"Not Available"

Availability:"Running or Full Power"

Caption:"Intel64 Family 6 Model 69 Stepping 1"

- "Chipset Name":"Intel(R) Core(TM) i7-4600U CPU @ 2.10GHz"

Link:" http://www.intel.com/content/www/us/en/search.html?keyword=Core+i7+4600U+CPU+"

CPU Speed:"2.70 GHz"

Current Voltage:"1.8 volts"

Driver:"Not Available"

Driver Date:"04/21/2009 12:00 AM"

Driver Path:"C:\WINDOWS\system32\drivers\intelppm.sys"

Driver Provider:"Microsoft"

Driver Version:"10.0.17134.1"

Ext. Family:"Not Available"

Family:"Intel Core™ i7-2760QM"

FPO:"Not Available"

INF:"cpu.inf"

INF Section:"IntelPPM_Inst.NT"

Install Date:"Not Available"

Last Error Code:"Not Available"

Level 1 Cache:"2 x 128 KB"

Level 2 Cache:"2 x 512 KB"

Level 3 Cache:"4 MB"

Load:"10%"

Manufacturer:"GenuineIntel"

Model:"69"

Name:"Intel(R) Core(TM) i7-4600U CPU @ 2.10GHz"

Number of Cores:"2"

Number of Cores Enabled:"2"

Number of Logical Processors:"4"

Part Number:"Fill By OEM"

Power Management Capabilities:"Not Available"

Power Management Supported:"No"

Processor ID:"BFEBFBFF00040651"

Revision:"17665"

Serial Number:"Not Available"

Service Name:"intelppm"

Status:"OK"

Stepping:"1"

Version:"Not Available"

- "Storage"

- "SAMSUNG SSD SM841 mSATA 128GB"

Capablities:"Random Access, Supports Writing, SMART Notification"

Caption:"SAMSUNG SSD SM841 mSATA 128GB"

Cylinder - Total:"15566"

Description:"Disk drive"

Driver:"Not Available"

Driver Date:"06/21/2006 12:00 AM"

Driver Version:"10.0.17134.1"

Error Code:"Device is working properly"

Firmware Revision:"DXM43D0Q"

Heads - Total:"255"

Index:"0"

INF:"disk.inf"

Install Date:"Not Available"

Interface Type:"SCSI"

Manufacturer:"(Standard disk drives)"

Model:"SAMSUNG SSD SM841 mSATA 128GB"

Name:"\\.\PHYSICALDRIVE0"

Partitions:"2"

Physical Sector Size:"512"

PNP Device ID:"SCSI\DISK&VEN_SAMSUNG&PROD_SSD\4&27971287&0&000100"

Policies:"Read Retention Priority=EqualPriority, Write Retention Priority=EqualPriority, Sc...

0 Kudos
16 Replies
idata
Community Manager
1,179 Views

Hello, mb735. Thank you very much for taking the time to reach the Intel Communities Team. I will do my best to assist you further.

 

 

Basically, the Intel® Rapid Storage Technology (Intel® RST) version provided by your system manufacturer (14.8.1.1043 ,A14) has been modified and optimized for your system nonetheless, you should not have any problem if you use the RST provided by Intel® (version 16.0.2.1086). If you are not having any issues with the 16.0.2.1086 version, there is no need to go back to the DELL* version but, if you find any issues, you can rollback to the 14.8.1.1043,A14 version.

 

 

Here is the link for the Intel® RST 16.0.2.1086: https://downloadcenter.intel.com/download/27681/Intel-Rapid-Storage-Technology-Intel-RST-User-Interf... https://downloadcenter.intel.com/download/27681/Intel-Rapid-Storage-Technology-Intel-RST-User-Interf...

 

Here is the link for the Intel® RST 14.8.1.1043 ,A14: https://downloads.dell.com/FOLDER03476708M/1/Serial-ATA_Driver_YN1KH_WN64_14.8.1.1043_A14.EXE https://downloads.dell.com/FOLDER03476708M/1/Serial-ATA_Driver_YN1KH_WN64_14.8.1.1043_A14.EXE

 

 

 

Antony S.
MBeck4
Beginner
1,179 Views

Hi Antony. Thanks very much for your helpful (and reassuring) reply.

I have not noticed any problems related to the RST issue. I nonetheless tried to reinstall RST 14.8.1.1043,A14 using the link you provided me, which I believe was the same EXE I had used several times before (before your reply, when I found it via the Dell site). However - like before - I'm not entirely confident that these reinstallations "took".

Can you advise me on how to verify which version - IF any! - is actually in use on my system now?

Thanks again,

Miles

idata
Community Manager
1,179 Views

Thank you very much for your reply, mb735.

 

 

For you to verify the version of the Intel® Rapid Storage Technology you have installed go to the "Help" tab on the Intel® RST interface and on the pop-up, click on about. You should be able to see the version of the software on the bottom right corner.

 

 

 

Antony S.
MBeck4
Beginner
1,179 Views

Thanks, Antony. The problem is that the interface itself is no longer installed; I uninstalled it (from the Control Panel) earlier, when I was originally trying to roll back from v16 to v14.

So right now I do not have a executable RST application installed.

Whenever I try to reinstall the v14 (from the link you sent me, for example), it reports that the installation was successful, but it does not install an interface. I'm assuming it's just a driver. How, then, to reinstall the interface that goes along with the v14 driver?

This is why I am not sure whether RST is actually functioning now on my machine in any way. Can it function as a driver in the absence of the interface?

MBB

idata
Community Manager
1,179 Views

Hello, mb735. Thank you for your response.

 

 

The v14 version is the Intel® RST provided by your mainboard manufacturer, this should install the software itself. If you are not able to see the RST interface after installing the DELL* version, try installing the 16.0.2.1086 version I attached above.

 

 

 

Antony S.
MBeck4
Beginner
1,179 Views

Antony,

I was unable to reinstall the v14 RST software via the Dell link you sent me, so I took your advice and (re-)installed the v16 software from Intel. It installed and appears to be running normally, but I did get a popup at the end of installation with an error notification: "Unable to inject the driver into Windows Recovery partition". I've pasted it in below for your reference. (I got the same popup the first time I installed the v16 RST, before I contacted Intel, and it's one of the things that concerned me at the time.)

Is this something that needs to be addressed, and if so, how can that be done?

I appreciate your ongoing help.

idata
Community Manager
1,179 Views

Hello, mb735. Thank you for the update.

 

 

Do you have an Intel® Optane™ memory installed on your system? If so, please provide me with the model of it.

 

 

 

Antony S.
MBeck4
Beginner
1,179 Views

Hi Antony,

No, I don't think I have Optane memory on my system. It is a notebook with an internal SSD, and the system predates the introduction of Optane.

idata
Community Manager
1,179 Views

Thank you very much for replying back, mb735.

 

 

Please try this link: https://downloadmirror.intel.com/27681/eng/SetupRST.exe https://downloadmirror.intel.com/27681/eng/SetupRST.exe

 

Uninstall the current version of RST on your computer and then install the .exe of the link attached.

 

 

 

Antony S.
MBeck4
Beginner
1,179 Views

Thanks for your reply, Antony.

I followed the instructions in your last message. When I did so, the pattern was the same as it has been in the past, as detailed below.

1. I uninstalled RST software using the Control Panel. It appears to have successfully uninstalled the software, but not the driver itself, as confirmed by the following pop-up I received at the beginning of the procedure:

2. I then reinstalled RST using the link you provided. Once again, the following pop-up appeared:

Thanks,

mb735

idata
Community Manager
1,179 Views

Hello, mb735. Thank you for informing about this.

 

 

Let's try installing the 15.9 version of Intel® RST. Here is the download link: https://downloadmirror.intel.com/27400/eng/SetupRST.exe https://downloadmirror.intel.com/27400/eng/SetupRST.exe

 

Please make sure you uninstall RST from Program and Features, restart the computer and then install the new version.

 

 

 

Antony S.
MBeck4
Beginner
1,179 Views

Thanks, Antony. I followed your instructions and uninstalled the v16 RST, restarted the computer, and then installed the v.15.9 RST from your link.

The results were the same.

- Before the v16 uninstall, I received the notification that only the interface software -- not the driver itself -- could be uninstalled.

- After the v15 install, I received the same pop-up notification:

Otherwise, the computer still appears to be functioning normally.

mb735

idata
Community Manager
1,179 Views

Thank you very much for your response, mb735.

 

 

When you install the Intel® RST version from your system manufacturer, do you have the same message?

 

Here is the download link: https://downloads.dell.com/FOLDER03476708M/1/Serial-ATA_Driver_YN1KH_WN64_14.8.1.1043_A14.EXE https://downloads.dell.com/FOLDER03476708M/1/Serial-ATA_Driver_YN1KH_WN64_14.8.1.1043_A14.EXE

 

 

 

Antony S.
MBeck4
Beginner
1,179 Views

Antony,

No. When I reinstall the Dell v14 version, I am first notified that the installation was a success:

However, when I then open the RST software and check on what version is running, it reports that the previous version is still installed:

Note that, as discussed earlier in this thread, the Dell RST v14 link does not appear to install the v14 RST *software*. It only installs the v14 RST *drivers* -- or at least it says it does.

So when I attempt to check on the version using the RST software, it still says I'm using the v15 that was previously installed.

I wondered if that was because the "v15" refers only to the software, and not to the driver, in which case the v14 driver itself might still have been successfully rolled back when I performed the installation from the Dell link.

BUT when I look at my device manager for corroboration, it tells me that the driver for my drive is still the v15 version! (See below.) That suggests that the v14 driver was never reinstalled after all, even though the installation was reported to have been successful:

This is the same pattern that occurred before, when I was trying to resolve this uncertainty myself, and it's precisely why I became doubtful that the Dell v14 link was actually reinstalling the old driver.

Here, by the way, is the log for the v14 installation file. I have no idea if it tells us anything useful, but I do note that there is an entry saying that the "Local System/Model" is *not* compatible with this package.

[05/02/18 14:09:32] Update Package Execution Started

[05/02/18 14:09:32] Original command line: "C:\ProgramData\PCDr\6875\Drivers\Serial-ATA_Driver_YN1KH_WN64_14.8.1.1043_A14.EXE" /s

[05/02/18 14:09:32] DUP Framework EXE Version: 3.4.1.76

[05/02/18 14:09:32] DUP Release: YN1KHA14

[05/02/18 14:09:32] Initializing framework...

[05/02/18 14:09:32] User Command: unattended

[05/02/18 14:09:32] DUP Capabilities Value: 35651583 (0x21FFFFF)

[05/02/18 14:09:32] DUP Vendor Software Version: 14.8.1.1043

[05/02/18 14:09:32] System ID: 05CB

[05/02/18 14:09:32] System model description: Latitude E7440

[05/02/18 14:09:32] Local System/Model Compatible with this Package? No

[05/02/18 14:09:32] Local System OS Version: 10.0.0.0

[05/02/18 14:09:32] OS Compatible with this Package? Yes

[05/02/18 14:09:32] Local System OS Language: EN

[05/02/18 14:09:32] Language Compatible with this Package? Yes

[05/02/18 14:09:32] Extraction-miniunz path: C:\PROGRA~3\dell\drivers\SERIAL~1.104\miniunz.exe

[05/02/18 14:09:32] Extraction-arguments: -x C:\PROGRA~3\PCDr\6875\Drivers\SERIAL~1.EXE -o -d C:\PROGRA~3\dell\drivers\SERIAL~1.104

[05/02/18 14:09:33] Extraction-GetExitCode: 0

[05/02/18 14:09:33] Identified Behavior : unattended

[05/02/18 14:09:33] Temporary payload log file name: C:\ProgramData\dell\drivers\Serial-ATA_Driver_YN1KH_WN64_14.8.1.1043_A14\DUPCB93.tmp

[05/02/18 14:09:33] Translated Command Line : dpInstScript-x64.bat /q /l C:\ProgramData\dell\drivers\Serial-ATA_Driver_YN1KH_WN64_14.8.1.1043_A14\DUPCB93.tmp

[05/02/18 14:09:33] Path : C:\ProgramData\dell\drivers\Serial-ATA_Driver_YN1KH_WN64_14.8.1.1043_A14

[05/02/18 14:09:33] Identified Behavior : unattended

[05/02/18 14:09:36] Append Vendor Software Log: C:\ProgramData\dell\drivers\Serial-ATA_Driver_YN1KH_WN64_14.8.1.1043_A14\DUPCB93.tmp

[05/02/18 14:09:36]

 

--- Start of Vendor Software Log ---

 

[05/02/18 14:09:36]

 

--- End of Vendor Software Log ---

 

[05/02/18 14:09:36] Vendor Software Return Code: 0

[05/02/18 14:09:36] Name of Exit Code: SUCCESS

[05/02/18 14:09:36] Exit Code set to: 0 (0x0)

[05/02/18 14:09:36] Result: SUCCESS

[05/02/18 14:09:36] Name of Exit Code: SUCCESS

[05/02/18 14:09:36] Execution terminated at date-time 05/02/18 14:09:36

[05/02/18 14:09:36] #

 

idata
Community Manager
1,179 Views

Hello, mb735.

 

 

It seems that the DELL's* update tool is automatically installing the v15 of the RST. I suggest you to double check this with http://www.dell.com/support/home/us/en/04/products/laptop DELL* Support if there is a limitation set by them for you to only use the RST provided by them and why the system shows a different version.

 

 

 

Antony S.
MBeck4
Beginner
1,179 Views

Hi Antony,

Picking up this thread after a long delay. Sorry to have left it open so long.

Actually, I think the problem is that Dell's V14 update tool simply can't roll back the driver earlier than the v15 version, if the v15 driver is already installed on the machine.

Consider:

- When I uninstall the v15 package, it removes the v15 interface but not the v15 driver (as reported by my Device Manager). The v15 driver remains in place.

- When, after that, I attempt to reinstall through Dell's v14 installer, it: (1) does not install any RST interface at all; and (2) leaves the v15 driver in place (according to my Device Manager). This is the result even though the v14 installation is reported to have been "successful".

in other words, once I've updated the driver to v15 or v16, it appears impossible to go back to v14, at least through the v14 Dell installation tool that we have been working with.

All that said, I think I'm comfortable leaving the situation as-is for now. I haven't been noticing any performance issues over the last month.

I appreciate your work trying to figure this out.

mb735

Reply