Community
cancel
Showing results for 
Search instead for 
Did you mean: 
lflet
Beginner
2,614 Views

Update Intel Rapid Storage Technology Driver on Windows 10

Hi Support,

Windows 10 recently forced itself upon me and since then I have been experiencing a 'driver_power_state_failure' Blue Screen of Death on my fist attempt to boot the laptop. The machine restarts itself and successfully starts on the second attempt but the whole process take about 5 minutes.

 

I was previously on a windows 8.1 version and everything was working fine.

I have tried to update my Intel Rapid Storage Technology Driver with the latest 14.8.0.1042 (Latest) version but it fails due to the below error:

2015:02:21 01:32:33:211:

2015:02:21 01:32:33:211: >>> Log start

2015:02:21 01:32:33:211: Single-instance mutex has been obtained

2015:02:21 01:32:33:211: Core version: 2.5.34

2015:02:21 01:32:33:211: Setup version: 2.1.7.0

2015:02:21 01:32:33:211: Command line: "C:\Users\Lumness\Downloads\SetupRST.exe"

2015:02:21 01:32:33:211: OS data: 6-2-1-0 64-bit

2015:02:21 01:32:33:211: System up time: 2499 sec

2015:02:21 01:32:33:211: Reboot pending: No

2015:02:21 01:32:33:211: Current UI language: 0809

2015:02:21 01:32:33:211: Language folder: C:\Users\Lumness\AppData\Local\Temp\IIF2215.tmp

2015:02:21 01:32:33:211: Found C:\Users\Lumness\AppData\Local\Temp\IIF2215.tmp\ar-SA\IntelCommon.dll. Lang 0401. Rank 0

2015:02:21 01:32:33:226: Found C:\Users\Lumness\AppData\Local\Temp\IIF2215.tmp\cs-CZ\IntelCommon.dll. Lang 0405. Rank 0

2015:02:21 01:32:33:273: Found C:\Users\Lumness\AppData\Local\Temp\IIF2215.tmp\da-DK\IntelCommon.dll. Lang 0406. Rank 0

2015:02:21 01:32:33:305: Found C:\Users\Lumness\AppData\Local\Temp\IIF2215.tmp\de-DE\IntelCommon.dll. Lang 0407. Rank 0

2015:02:21 01:32:33:320: Found C:\Users\Lumness\AppData\Local\Temp\IIF2215.tmp\el-GR\IntelCommon.dll. Lang 0408. Rank 0

2015:02:21 01:32:33:336: Found C:\Users\Lumness\AppData\Local\Temp\IIF2215.tmp\en-US\IntelCommon.dll. Lang 0409. Rank 2

2015:02:21 01:32:33:351: Found C:\Users\Lumness\AppData\Local\Temp\IIF2215.tmp\es-ES\IntelCommon.dll. Lang 0C0A. Rank 0

2015:02:21 01:32:33:351: Found C:\Users\Lumness\AppData\Local\Temp\IIF2215.tmp\fi-FI\IntelCommon.dll. Lang 040B. Rank 0

2015:02:21 01:32:33:367: Found C:\Users\Lumness\AppData\Local\Temp\IIF2215.tmp\fr-FR\IntelCommon.dll. Lang 040C. Rank 0

2015:02:21 01:32:33:383: Found C:\Users\Lumness\AppData\Local\Temp\IIF2215.tmp\he-IL\IntelCommon.dll. Lang 040D. Rank 0

2015:02:21 01:32:33:383: Found C:\Users\Lumness\AppData\Local\Temp\IIF2215.tmp\hu-HU\IntelCommon.dll. Lang 040E. Rank 0

2015:02:21 01:32:33:398: Found C:\Users\Lumness\AppData\Local\Temp\IIF2215.tmp\it-IT\IntelCommon.dll. Lang 0410. Rank 0

2015:02:21 01:32:33:398: Found C:\Users\Lumness\AppData\Local\Temp\IIF2215.tmp\ja-JP\IntelCommon.dll. Lang 0411. Rank 0

2015:02:21 01:32:33:414: Found C:\Users\Lumness\AppData\Local\Temp\IIF2215.tmp\ko-KR\IntelCommon.dll. Lang 0412. Rank 0

2015:02:21 01:32:33:414: Found C:\Users\Lumness\AppData\Local\Temp\IIF2215.tmp\nb-NO\IntelCommon.dll. Lang 0414. Rank 0

2015:02:21 01:32:33:430: Found C:\Users\Lumness\AppData\Local\Temp\IIF2215.tmp\nl-NL\IntelCommon.dll. Lang 0413. Rank 0

2015:02:21 01:32:33:445: Found C:\Users\Lumness\AppData\Local\Temp\IIF2215.tmp\pl-PL\IntelCommon.dll. Lang 0415. Rank 0

2015:02:21 01:32:33:461: Found C:\Users\Lumness\AppData\Local\Temp\IIF2215.tmp\pt-BR\IntelCommon.dll. Lang 0416. Rank 0

2015:02:21 01:32:33:461: Found C:\Users\Lumness\AppData\Local\Temp\IIF2215.tmp\pt-PT\IntelCommon.dll. Lang 0816. Rank 0

2015:02:21 01:32:33:476: Found C:\Users\Lumness\AppData\Local\Temp\IIF2215.tmp\ru-RU\IntelCommon.dll. Lang 0419. Rank 0

2015:02:21 01:32:33:492: Found C:\Users\Lumness\AppData\Local\Temp\IIF2215.tmp\sv-SE\IntelCommon.dll. Lang 041D. Rank 0

2015:02:21 01:32:33:508: Found C:\Users\Lumness\AppData\Local\Temp\IIF2215.tmp\th-TH\IntelCommon.dll. Lang 041E. Rank 0

2015:02:21 01:32:33:523: Found C:\Users\Lumness\AppData\Local\Temp\IIF2215.tmp\tr-TR\IntelCommon.dll. Lang 041F. Rank 0

2015:02:21 01:32:33:523: Found C:\Users\Lumness\AppData\Local\Temp\IIF2215.tmp\zh-CN\IntelCommon.dll. Lang 0804. Rank 0

2015:02:21 01:32:33:539: Found C:\Users\Lumness\AppData\Local\Temp\IIF2215.tmp\zh-TW\IntelCommon.dll. Lang 0404. Rank 0

2015:02:21 01:32:33:539: Loading language 0409

2015:02:21 01:32:33:617: Relaunching setup as elevated

2015:02:21 01:32:36:021:

2015:02:21 01:32:36:021: >>> Log start

2015:02:21 01:32:36:021: Dumping properties (21 total)

2015:02:21 01:32:36:021: IIF_MSILOGLEVEL=4096

2015:02:21 01:32:36:021: IIF_LOGFOLDER=C:\Users\Lumness\Intel\Logs

2015:02:21 01:32:36:021: IIF_SETUPVERSION=2.1.7.0

2015:02:21 01:32:36:021: IIF_PACKAGEVERSION=13.2.4.1000

2015:02:21 01:32:36:021: IIF_SETUPPATH=C:\Users\Lumness\Downloads

2015:02:21 01:32:36:021: IIF_CACHELOC=C:\ProgramData\Intel\Package Cache\{409CB30E-E457-4008-9B1A-ED1B...

0 Kudos
8 Replies
Allan_J_Intel1
Employee
608 Views

You need to make sure your computer is fully compatible with Windows® 10.

Please provide your computer model number or the chipset type on your computer.

Allan.

lflet
Beginner
608 Views

My machine is an ASUS UX32A.

 

It's running quad Intel(R) Core(TM) i5-3317U CPU @ 1.70GHz processors.
Allan_J_Intel1
Employee
608 Views

Thanks for the information.

Download and try installing the latest Intel® Rapid Storage 14.8 https://downloadcenter.intel.com/download/25165/Intel-Rapid-Storage-Technology-Intel-RST-RAID-Driver Download Intel® Rapid Storage Technology (Intel® RST) RAID Driver

Please bear in mind that you will try to install software that may or may not work for your system. This will depend on your computer maker. It is recommended to install customized drivers from your computer manufacturer.

Allan.

lflet
Beginner
608 Views

Hi Allan,

I have already tried to install that driver (14.8.0.1042 (Latest) version) as stated in my original post but it failed with the error log as reported originally.

I am currently talking to ASUS support to see if they are able to provide customized drivers but they haven't been able to so far.

 

I was hoping the supplied error log would be able to provide a reason why the installation failed and hence a solution could be drawn up.

Liam

Allan_J_Intel1
Employee
608 Views

Thank you for the information. I hope you can get customized Intel® Rapid Storage software for your computer model.

Allan

FHeik
New Contributor II
608 Views

The ASUS UX32A is based on an Intel 7-series chipset (HM76); for those, the recommended Intel RST/AHCI drivers are the ones from the 12.x or 13.x release branches. The latest ones seem to be v12.9.4.1000, which can be downloaded http://www.station-drivers.com/index.php?option=com_remository&Itemid=353&func=fileinfo&id=687&lang=... here (scroll down), and v13.6.2.1001, which can be downloaded http://www.station-drivers.com/index.php?option=com_content&view=article&id=1296&lang=en here.

Note that these drivers aren't officially supported in Windows 10, since that OS didn't exist by the time those drivers have been released. They should work nonetheless.

The drivers from the 14.x release branch you tried to install are supposed to be used with an Intel chipset system from 8-Series up.

Give it a try and lets us know if one of the drivers above works for you (it's recommended, though usually not necessary, to uninstall any installed RST/AHCI driver before installing a different one).

lflet
Beginner
608 Views

Hi YseGuy, thank you for the response.

I was unable to upgrade with the 13.6.0.1002 driver but I was successful with the 12.9.0.1001 driver installation. It didn't solve the issue however and I am still receiving the same BSOD. Asus support can't provide the correct windows 10 drivers as they aren't available yet, such a joke.

 

At this stage I will just roll back to windows 8.1.

Thanks for the support,

 

Liam
FHeik
New Contributor II
608 Views

I doubt ASUS will ever release Win10 drivers for an "old" product like the UX32A.

Anyway, there are still some things you could try:

  • Run Windows System File Checker (sfc /scannow) from an elevated command prompt (just to make sure there ain't a problem with your system files).
  • If memory dump creation is disabled, enable it, wait for the next BSOD, and analyze the dump file with a tool like http://www.nirsoft.net/utils/blue_screen_view.html BlueScreenView. This should give you the information which driver(s) cause the BSOD (or if dump creation is enabled already, analyze one of the existing dump files. They should be located in the OS root directory (C:\Windows)).
  • Run Windows Driver Verifier (built into the OS; search the Web on how to use it), for the same purpose (ie to identify problematic drivers).
  • Remove Intel RST/AHCI driver package altogether, and use the default drivers provided by the OS.
Reply