Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Rachel_D_
Beginner
84 Views

Bower Unknown Internal Error

I'm running Intel XDK Version 3522, I'm working on a Mac, OS X El Capitan 10.11.6. Just trying to install Bower package Ionic.

Any Advice would be appreciated.

 

Screen Shot 2016-09-06 at 6.03.00 PM.png

 

Tags (2)
0 Kudos
5 Replies
PaulF_IntelCorp
Employee
84 Views

I just tried doing the same thing with a blank sample app and it worked for me. Did you try exiting the XDK and restarting it?

Screen Shot 2016-09-07 at 5.55.40 PM.png

Jeff_G_1
Beginner
84 Views

I have this same error problem. 

Setup:

Clean install fo OS X Siera.

Installed Intel XDK

​Also installed latest version of git and bower.

Bower works great from the terminal

Reading some other posts, this is what I tried and nothing worked yet.

Added the url https = git in my git config file

Played with the Git settings under options in Intel XDK
Set custom git path to something incorrect - managed to get an error that it couldn't find git
Set customer git path to my installed git location, no help - same Unknown Internal Error
Changed proxy configuration to Manual, no help. Changed back, no help. (restarted XDK after each change before trying to load a bower package)

I can not find a log file for XDK, where is it located in OS X?

Are there prerequisites for using bower in the XDK? Do I need to manually edit some file in the project first? It mentions a bower.json file in some of the help info but one is not created in my project already. And using bower.init from the terminal, I can't seem to put it or the packages in the right location.

I really like this IDE, and would love to get it working on my Mac.

 

 

 

PaulF_IntelCorp
Employee
84 Views

There is an xdk.log file. On a Mac it's located here > ~/Library/Application Support/XDK < it gets regenerated each time you start the XDK.

There are no specific prerequisites for using bower with the XDK, it does attempt to force a few configuration options that are outside the normal bower behavior. There is, however, no requirement that you use the built-in bower feature. If you cannot get it to work within the XDK I recommend that you disable the XDK bower tool and just use the command-line tool:

Screen Shot 2016-12-06 at 10.00.37 .png

In the example above I used the command-line bower tool to install the moment and ua-parser-js libs into my project, so there is a bower.json file in my project folder and a bower_components folder.

I then make a hard link from www/lib/moment.js and www/lib/ua-parser.js to the respective files in the bower_components folder (which is located at the root of the project folder) so only those files are included in my build package (you don't need all the other junk that bower retrieves). That is why the internal bower tool is seeing these libraries but complaining they are not installed, they are present in my project, it's just that the XDK bower tool did not retrieve them for me.

It's very important that you first turn off the "automatically sync" option in your project before you do this. Otherwise, the XDK will overwrite what you did at the command-line. This approach also gives you more control over what's included in your built package and how and when to update any bower libraries.

Jeff_G_1
Beginner
84 Views

Thanks for the info. Once I had the log I was able to see the error.

bower-commands:[2016-12-06T23:12:38.683Z]: (1481065958683): Error getting detailed information for package jQuery { [Error: null]
  code: 7,
  message: null,
  originalMessage: null,
  originalError: 
   { code: 'ECMDERR',
     details: 'fatal: Unable to find remote helper for \'https\'\n',
     exitCode: 128 } } { directory: 'www/bower_components/',
  registry: 'https://bower.herokuapp.com',
  interactive: null,
  cwd: '/Users/jg/XDK/MyCordova/',
  storage: 
   { packages: '/Users/jg/Library/Application Support/XDK/.bower/packages',
     registry: '/Users/jg/Library/Application Support/XDK/.bower/registry',
     links: '/Users/jg/Library/Application Support/XDK/.bower/links' } }

And of course bower works fine from the terminal. So what's up with this remote helper for https? 

PaulF_IntelCorp
Employee
84 Views

Could have something to do with your bowerrc files? I believe the bower inside the XDK will still traverse the various bower config files, which might be causing the problem.

Reply