Community
cancel
Showing results for 
Search instead for 
Did you mean: 
nguetseng_s_
Beginner
34 Views

Build Problem

Hello everyone,I have a problem
I installed this plugin
https://github.com/markbirbeck/cordova-plugin-android-app-bar
the installation went very smoothly but when I try to compile this with the cloud build of xdk intel and crosswalk beta 22, it's fails and when I see the log i see this line
compileArmv7ReleaseJavaWithJavac.../cordova_project/platforms/android/src/com/markbirbeck/cordova/plugin/AppBarPlugin.java:50: error: strings in switch are not supported in -source 1.6
         switch (action) {
                ^
   (Use -source 7 Higher gold to enable strings in switch)
... / Cordova_project / platforms / android / src / com / markbirbeck / cordova / plugin / AppBarPlugin.java: 76: error: strings in switch are not supported in -source 1.6
         switch (id) {
                ^
   (Use -source 7 Higher gold to enable strings in switch)
how to have the source 7 being given that the compilation is in the cloud
Thank you

Tags (2)
0 Kudos
2 Replies
PaulF_IntelCorp
Employee
34 Views

Here's a pretty clear explanation of the problem > http://stackoverflow.com/questions/20829547/switch-statement-of-string < but, as you noted, you do not have access to the build system, so the simple solutions provided cannot be applied. You could, however, use the other suggestions and change the code in the plugin:

  • clone the plugin or download a ZIP of the plugin
  • modify the two locations in the problem JAVA file and change to handle non-string scenarios
  • import that plugin as a "local" third-party plugin into your project

I'll file an update request regarding the version of Java being used in our build system, but no guarantee as to when that update will occur.

nguetseng_s_
Beginner
34 Views

ok thank you i try now

 

Reply