Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Mike_C_4
New Contributor I
43 Views

Chrome DevTools

Hello,

I'm trying to get Chrome DevTools tools to work with my app. I followed the instruction loaded the debug drive and turn debug on my phone.

I tuned on debug in the  in my intelxdk.config.additions.xml file

 <platform name="android">

  <preference name="SplashMaintainAspectRatio" value="false" />

 <preference name="AndroidLaunchMode" value="singleTask" />

<application android:debuggable="true" />

</platform>

I launch my app on my phone (which I installed) and I  typed into chrome://inspec and I see my phone  but I don't see my app ? is there a additional step I might be missing?

I should mention this is not a Crosswalk app (yet getting a build failure which will be in a different post ) 

--


Thanks
Mike

 

Tags (2)
0 Kudos
2 Replies
PaulF_IntelCorp
Employee
43 Views

See this doc page > https://software.intel.com/en-us/xdk/docs/using-remote-chrome-devtools-to-debug-android-cordova-apps < -- that <application> tag you're using won't work, I believe it is meant for an Android Manifest file, which the intelxdk.config.additions.xml file does not modify, it includes a few Intel XDK commands and can be used to add standard Cordova config.xml commands.

0 Kudos
Mike_C_4
New Contributor I
43 Views

Hi Paul,

I found the issue, I was using weinre and had the script tag still active,  I now see my app. however the app preview I have does not support CLI 6.2 and there really isn't any support for the plugins I'm using. 

 

thanks again

 

0 Kudos