Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Alex_Hang
New Contributor II
51 Views

Cordova CLI Build failed

Hello everyone,

 When I build the app using the Intel Cloud build system, everything is working ok, and I am able to install the app on my phone. The problem is, when I build the app using Cordova CLI. Every time I try to build the app, i have the error from the bellow screenshot( the same app is building without errors using intel cloud building service).

Note: I have Java 1.8 installed, that is not the problem.

can anyone please help me? Have a good day,

                     Alex Hang

Tags (2)
0 Kudos
5 Replies
PaulF_IntelCorp
Employee
51 Views

I suspect this is due to having installed the latest version of Cordova CLI and/or the latest version of the cordova-android framework (what you get when you use the command "cordova platform add android"). My recollection is that with the latest versions of those items you may need to use the latest version of the Crosswalk plugin.

If you look in the config.xml file you'll see that a specific version of Crosswalk is being requested (probably 19), the last version produced is 23, but if you remove the version specifier for the Crosswalk plugin you'll get the latest. I'd try that to see if it resolves the issue or simply remove Crosswalk from your Build Settings and create a new config.xml and see if it builds without Crosswalk. 

If you are only targeting Android 5+ devices you don't really need to be using Crosswalk. If you are targeting Android 4.4+ devices and your UI and JavaScript features are not terribly complex you can also stop using Crosswalk. Crosswalk is most useful for targeting Android 4.x devices, newer devices (Android 5 and greater) do not need it for the vast majority of apps.

0 Kudos
Alex_Hang
New Contributor II
51 Views

Thank you very much sir, I will try to build without crosswalk
0 Kudos
PaulF_IntelCorp
Employee
51 Views

Also curious if the build succeeds with PhoneGap Build, since the config.xml file that is created specifies some specific CLI and plugin versions, which should work there. Unlike using Cordova CLI, where you only have one version of the build tools, you have access to many versions on PGB, and the config.xml is very specific, just as the XDK build system is. So I would expect a build on PGB to work, which would point to further evidence that the version of CLI you are running is what's creating the conflict.

0 Kudos
Alex_Hang
New Contributor II
51 Views

I tried to remove the crosswalk, to change the min-sdk, the target sdk, and many others, but it's still not working.

But something is very weird: the same zip archive I used when trying to build the app using Cordova CLI, was working fine, without errors on PhoneGap Build.... No error, but same file. This proves that Intel XDk package build system is working perfectly, the problem is at Cordova CLI, Thank you once again for everything !

0 Kudos
johan_p_1
Beginner
51 Views

any solution? i have this problem cordova 7.1.0

0 Kudos