Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Joaquin_C_
Beginner
62 Views

Debuggable set to false, after setting it to true. IntelXDK, Construct2, Android


Im developing a Construct2 game and exported with cordova to intelXDK.
Everything works fine except that i manually set te debuggable option to true inside the intelxdk.config.android.xml. And when im building the apk, it sets back to false.
I need it to be true in order to monitor it with the Android Studio.

Any Idea?

Regards.
 

Tags (2)
0 Kudos
3 Replies
Alex_Hang
New Contributor II
62 Views

You changed the debuggable option to true only in the xml file?

Try to check If you didn't have unchecked by mistake a debuggable option checkbox or other field in the Build Settings.

It's just my ideea, so I am sorry if this is not the real solution.

Joaquin_C_
Beginner
62 Views

Yes, i changed only in that document,

But I already fixed it, i had to change it on the  intelxdk.config.additions.xml.

This will change the debuggable option for every platform.

Alex Hang wrote:

You changed the debuggable option to true only in the xml file?

Try to check If you didn't have unchecked by mistake a debuggable option checkbox or other field in the Build Settings.

It's just my ideea, so I am sorry if this is not the real solution.



Where are the debug checkbox options?
There is nothing related to debug in the Build Settings, at least i didnt see them.

Thanks for you reply :)

PaulF_IntelCorp
Employee
62 Views

Joaquin C. wrote:

...i had to change it on the  intelxdk.config.additions.xml. This will change the debuggable option for every platform.

That "debuggable" equal "true" setting in the "intelxdk.config.additions.xml" file only affects Android builds. If you want to create a debuggable iOS app you will need a Mac and you must build with a dev certificate. See these doc pages for more help with debugging an iOS app with a Mac > https://software.intel.com/en-us/xdk/docs/using-web-inspector-remote-to-debug-ios-cordova-apps < and for an overview of your debugging options > https://software.intel.com/en-us/xdk/docs/intel-xdk-debug-and-test-overview <

Alex Hang wrote:

Try to check If you didn't have unchecked by mistake a debuggable option checkbox or other field in the Build Settings.

There is no "debug" option in the Build Settings, only that "debuggable" option in the additions file for Android devices.

Reply