Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Leonidas_S_
New Contributor I
135 Views

Error: A build error occurred. Check the build log.

I get // during iOS build - 

Command finished with error code 2:

You may not have the required environment or OS to build this project

Error: .../PolisTravelGuide2015/platforms/ios/cordova/build: Command failed with exit code 2

well?

 

 

The build failed.

An error occurred while building the application. Verify your build assets are correct and try again.

You can view the detailed log of the iOS build here

Build Log:

  • Building a Cordova 5.1.1 application.
  • The application name is "Polis Cyprus"
  • The package name is "town.polis.ios"
  • Will use the provisioning profile for "production"
  • Plugin "cordova-plugin-device" (1.0.1) installed.
  • Plugin "cordova-plugin-splashscreen" (2.1.0) installed.
  • Plugin "cordova-plugin-contacts" (1.1.0) installed.
  • Plugin "cordova-plugin-geolocation" (1.0.1) installed.
  • Plugin "cordova-plugin-battery-status" (1.1.0) installed.
  • Targeting iOS version 8.0.
  • Error: A build error occurred. Check the build log.

 

Libtool build/CordovaLib.build/Release-iphoneos/CordovaLib.build/Objects-normal/armv7/libCordova.a normal armv7

    cd .../PolisTravelGuide2015/platforms/ios/CordovaLib

    export IPHONEOS_DEPLOYMENT_TARGET=8.0

    export PATH="/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/usr/bin:/Applications/Xcode.app/Contents/Developer/usr/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/local/git/bin:/Developer/android-sdk-macosx/tools:/usr/local/ant/bin"

    /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/libtool -static -arch_only armv7 -syslibroot /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS8.0.sdk -L.../PolisTravelGuide2015/platforms/ios/build/device -filelist .../PolisTravelGuide2015/platforms/ios/CordovaLib/build/CordovaLib.build/Release-iphoneos/CordovaLib.build/Objects-normal/armv7/Cordova.LinkFileList -o .../PolisTravelGuide2015/platforms/ios/CordovaLib/build/CordovaLib.build/Release-iphoneos/CordovaLib.build/Objects-normal/armv7/libCordova.a

 

CreateUniversalBinary .../PolisTravelGuide2015/platforms/ios/build/device/libCordova.a normal armv7\ armv7s\ arm64

    cd .../PolisTravelGuide2015/platforms/ios/CordovaLib

    export PATH="/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/usr/bin:/Applications/Xcode.app/Contents/Developer/usr/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/local/git/bin:/Developer/android-sdk-macosx/tools:/usr/local/ant/bin"

    /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/libtool -static .../PolisTravelGuide2015/platforms/ios/CordovaLib/build/CordovaLib.build/Release-iphoneos/CordovaLib.build/Objects-normal/armv7/libCordova.a .../PolisTravelGuide2015/platforms/ios/CordovaLib/build/CordovaLib.build/Release-iphoneos/CordovaLib.build/Objects-normal/armv7s/libCordova.a .../PolisTravelGuide2015/platforms/ios/CordovaLib/build/CordovaLib.build/Release-iphoneos/CordovaLib.build/Objects-normal/arm64/libCordova.a -o .../PolisTravelGuide2015/platforms/ios/build/device/libCordova.a

 

=== BUILD TARGET Polis Cyprus OF PROJECT Polis Cyprus WITH CONFIGURATION Release ===

 

Check dependencies

Code Sign error: No codesigning identities found: No codesigning identities (i.e. certificate and private key pairs) that match the provisioning profile specified in your build settings (“XDK_APP_STORE_PCAPP”) were found.

CodeSign error: code signing is required for product type 'Application' in SDK 'iOS 8.0'

 

** BUILD FAILED **

 

 

The following build commands failed:

                Check dependencies

(1 failure)

Error code 65 for command: xcodebuild with args: -xcconfig,.../PolisTravelGuide2015/platforms/ios/cordova/build-release.xcconfig,-project,Polis Cyprus.xcodeproj,ARCHS=armv7 armv7s arm64,-target,Polis Cyprus,-configuration,Release,-sdk,iphoneos,build,VALID_ARCHS=armv7 armv7s arm64,CONFIGURATION_BUILD_DIR=.../PolisTravelGuide2015/platforms/ios/build/device,SHARED_PRECOMPS_DIR=.../PolisTravelGuide2015/platforms/ios/build/sharedpch

Command finished with error code 2: .../PolisTravelGuide2015/platforms/ios/cordova/build --release,--device

ERROR building one of the platforms: Error: .../PolisTravelGuide2015/platforms/ios/cordova/build: Command failed with exit code 2

You may not have the required environment or OS to build this project

Error: .../PolisTravelGuide2015/platforms/ios/cordova/build: Command failed with exit code 2

    at ChildProcess.whenDone (/Developer/cordova/5.1.1/node_modules/cordova/node_modules/cordova-lib/src/cordova/superspawn.js:134:23)

    at ChildProcess.EventEmitter.emit (events.js:98:17)

    at maybeClose (child_process.js:753:16)

    at Process.ChildProcess._handle.onexit (child_process.js:820:5)

 

 

 

 

 

 

 

 

 

 

 

Tags (2)
0 Kudos
1 Reply
Rakshith_K_Intel
Employee
135 Views

Looks like you don't have the correct iOS certificate and provision profile setup: Please follow these instructions to create a certificate and provision profile:

https://software.intel.com/en-us/xdk/articles/walkthrough-obtain-ios-appstore-adhoc-cert

Reply