Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Victor_F_1
Beginner
65 Views

Error: Plugin BarcodeScanner cannot be added. The plugin contains Gradle scripts.

Hi

I'm getting this error message "Plugin BarcodeScanner cannot be added. The plugin contains Gradle scripts" when I try to generate an .apk file

Same configuration works for iOS, I'm using com.phonegap.plugins.barcodescanner

Does anyone have a clue of how can this be fixed?

Thanks!!

Tags (2)
0 Kudos
1 Reply
Anthony_H_Intel
Employee
65 Views

Hi Victor-

Our build system does not support gradle dependencies, take a look at this FAQ for more information about this.

It sounds like you are using a newer version of the barcode scanner than the one that is available via the Intel XDK Plugin Manager.

The latest version we support is 4.1.0 because a gradle dependency was added to the plugin after that version.

In order to resolve this, you can downgrade the version of the plugin to 4.1.0 or remove it and add the version that is provided via the Intel XDK Plugin Manager.

Hope this helps!
Tony

Reply