Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Mike_C_4
New Contributor I
102 Views

Error uploading to Google play

Okay I have never gotten this before and I have no idea how to fix it:

this happen when I upgraded to 3240

 

Tags (2)
0 Kudos
6 Replies
PaulF_IntelCorp
Employee
102 Views

Did you convert your "legacy" certificate and use that to build your app? If you created a new certificate and built with that new certificate you'll get this message. You have to continue to use the same certificate with each new update of your app to the store.

Mike_C_4
New Contributor I
102 Views

Paul,

I be honest I don't even remember downloading or creating a certificate and signing  the app in the old version of XDK? 

And yes I created a new one because that was the only option , even if I had the cert there is no way to load it into XDK? (unless I missed something)

I took a old version I had backup and open it in the new software 3240 and it never prompted me for a cert for android. 

Thanks

 

PaulF_IntelCorp
Employee
102 Views

The older versions managed the Android certs behind the scenes, which was convenient but was also a significant problem when things went awry. If you pull down the little man icon there is a cert management panel where you can manage certs and convert  the "legacy" cert associated with your account. If you did this then it should be in your account. If not, we can reset the flag that says you converted it so you can convert it again. Check that cert management panel to see if it is there. Watch this video (no audio) for a little help > https://software.intel.com/en-us/videos/upgrading-an-existing-intel-xdk-project-to-version-3088

You can add as many certs as you wish. There is an import function in that cert management tool.

Mike_C_4
New Contributor I
102 Views

Hi Paul,

First thank you. I was able to convert the cert  legacy cert over. ( I have no idea how I missed that) . The movie help a lot.

okay the bad news the below message is now what I get .

I see in the log that the package was on unsigned wondering if I missed something? Full log attached

BUILD SUCCESSFUL

Total time: 1 mins 6.593 secs
Built the following apk(s): 
    .../FamilyReunion/platforms/android/build/outputs/apk/android-release-unsigned.apk

 

 

 

PaulF_IntelCorp
Employee
102 Views

Did you check the "signed" box in the build settings?

Screen Shot 2016-05-06 at 5.45.59 PM.png

Mike_C_4
New Contributor I
102 Views

LOL yes. but you got me thinking. So unchecked close the app and then open and recheck the box and it work . Thanks for pointing that out.

Reply