Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Doddo_D_
Beginner
114 Views

Firebase plugin, Gradle etc.

Jump to solution

Hello,

I try to install this plugin: https://github.com/arnesson/cordova-plugin-firebase

But when I compile the app on Android, I get the famous "Gradle error"...

I tried to comment the line 

<framework src="src/android/build.gradle" custom="true" type="gradleReference" />

(following this: https://github.com/phonegap/phonegap-plugin-push/blob/master/docs/PHONEGAP_BUILD.md) ;

But I got this error:

http://pastebin.com/fScWtzu9

I also included the google-services.json file and .plist (IOS).

 

I really need Firebase for notifications and analytics... 

I tried OneSignal and Google Analytics plugins, but there a conflict with "gms" (can't remmember the exact conflict)

 

Does anybody knows an issue ?

 

Tags (2)
0 Kudos
1 Solution
Diego_Calp
Valued Contributor I
114 Views

Hello,

XDK not support gradle scripts.

You may use Firebase without the plugin, check this doc:

https://firebase.google.com/docs/web/setup

Read WEB tab (not NODE.JS)

Regards,

Diego

View solution in original post

4 Replies
Diego_Calp
Valued Contributor I
115 Views

Hello,

XDK not support gradle scripts.

You may use Firebase without the plugin, check this doc:

https://firebase.google.com/docs/web/setup

Read WEB tab (not NODE.JS)

Regards,

Diego

View solution in original post

Doddo_D_
Beginner
114 Views

Thanks for your reply, I'll check it :)

Doddo_D_
Beginner
114 Views

Analytics don't works on web based apps, am I right ?

Diego_Calp
Valued Contributor I
114 Views
Reply