Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Tiago_F_
Beginner
72 Views

IR LEFT and RIGH from R200 model

Hi to all!

When capturing the raw streams from IR images with the R200 model i get images like this one:

Sem Título_0.png

While when capturing with librealsense i get a normal IR image. Can anyone explain why this happens? 

0 Kudos
6 Replies
samontab
Valued Contributor II
72 Views

The images you posted here show the IR pattern projected by the camera. I assume you mean normal, as in, not showing a lot of "holes". Maybe the librelasense does not start the IR emitter automatically.

Try disabling the IR emitter, and check how the IR images look with daylight.

 

Tiago_F_
Beginner
72 Views

Hi samontab!

Thank you for the answer! With librealsense i get images like this:

 

cpp-headless-output-ir_0.png

As you can see it's a very different type of image... The first seems a stereoscopic image, and this is a classical IR image with patterns being shown. 

samontab
Valued Contributor II
72 Views

They look very similar to me.

Note that you are using 16bits in the RealSense SDK, so when converting to 8bits you get saturated levels.

Try getting 8bits, and you should get similar results.

Tiago_F_
Beginner
72 Views

samontab wrote:

They look very similar to me.

Note that you are using 16bits in the RealSense SDK, so when converting to 8bits you get saturated levels.

Try getting 8bits, and you should get similar results.

Most of the samples and codes said that IR images were in 8 bits, but if what you say is true that makes totally sense. Thanks samontab!

Tiago_F_
Beginner
72 Views

By the way is there possible to remove the pattern of the IR images? I tried to disable the emitter, but the images loss intensity...

samontab
Valued Contributor II
72 Views

Well, you can see it in your first screenshot, at the bottom. It says: Y16 628x468, which means it is using a 16 bits image, but the monitor is only able to display 8bits.

Regarding removing the IR pattern, sure, you need to disable the emitter, and of course you will get less intensity, because you just dimmed the lights!. Make sure to do that on a sunny day, and it will be bright.

Reply