Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Intel_C_5
Beginner
78 Views

Importing Construct2 Project [Simulation Error / Build Error] @BLACKSCREEN

Hi, i imported my Construct 2 project without any bugs in Intel XDK but i have a problem.

*This problem applys to all projects, I even tried a example to export using Intel XDK and it gave me the same problem.

So the problem is like this:

I import my Construct 2 (Cordova) project but if I try to Simulate / I export it as .apk and test it -> The result is just a blackscreen.

If i try to export it as apk again i tested many many times and it is just a blackscreen, no build error, also on the simulating screen just black.

What did i do wrong?

I asume this is happening after I upgraded Intel XDK.

What can i do ?

I uninstalled 2 times Intel XDK, no result. :(

Please help if you can,

Thank you in advance.

Tags (2)
0 Kudos
5 Replies
PaulF_IntelCorp
Employee
78 Views

I don't follow what you mean by:

I import my Construct 2 (Cordova) project but if I try to Simulate / I export it as .apk and test it -> The result is just a blackscreen.

If i try to export it as apk again i tested many many times and it is just a blackscreen, no build error, also on the simulating screen just black.

Do you mean that your app is "black" whether you run it in the Simulate tab or build it as an APK and run it on a device?

If that is what you mean, I suspect the problem has something to do with your app and not the XDK. No need to keep reinstalling the XDK. Try creating an app using the "hello cordova" app and see if that works in the Simulate tab and if that will run on your device when you build an APK. If so, then I suspect your app is "blocked" on something and cannot start. In other words, I suspect a logic error of some sort.

What do you see in the JavaScript debug console when you run it in the Simulate tab?

0 Kudos
Intel_C_5
Beginner
78 Views

Paul F. (Intel) wrote:

I don't follow what you mean by:

I import my Construct 2 (Cordova) project but if I try to Simulate / I export it as .apk and test it -> The result is just a blackscreen.

If i try to export it as apk again i tested many many times and it is just a blackscreen, no build error, also on the simulating screen just black.

Do you mean that your app is "black" whether you run it in the Simulate tab or build it as an APK and run it on a device?

If that is what you mean, I suspect the problem has something to do with your app and not the XDK. No need to keep reinstalling the XDK. Try creating an app using the "hello cordova" app and see if that works in the Simulate tab and if that will run on your device when you build an APK. If so, then I suspect your app is "blocked" on something and cannot start. In other words, I suspect a logic error of some sort.

What do you see in the JavaScript debug console when you run it in the Simulate tab?

 

Hi, i just created a template, and it works perfectly.

So on the problem with Construct 2  what should / can i do ?

Thank you very much.

0 Kudos
PaulF_IntelCorp
Employee
78 Views

Did you use the process outlined here to export and import your Construct2 app into the XDK? > https://software.intel.com/en-us/forums/intel-xdk/topic/607195 <

0 Kudos
Intel_C_5
Beginner
78 Views

Paul F. (Intel) wrote:

Did you use the process outlined here to export and import your Construct2 app into the XDK? > https://software.intel.com/en-us/forums/intel-xdk/topic/607195 <

 

Hi,

Yes, I have Construct 2 r221 so i'm using the tutorial from the "old Construct 2" right ?

It is not working, i arrange the folders with www how you explained in the tutorial but when i press simulate, again a blackscreen.

 

Here is the project file:

(i didn't used any plugins, just for test)

LINK : https://drive.google.com/open?id=0B2orsdOFRxeDQV9EanhveEhzZWc

 

 

0 Kudos
PaulF_IntelCorp
Employee
78 Views

The link I sent to you describes the "new" method (r225), which is what you need to use. The app that Construct2 exports is a Cordova app, which includes plugins. You imported your app as an HTML5 app, which does not support plugins. The Simulate tab gets confused when you do this, that is the reason it does not work. You need to use the new export method and the import process described in the post I gave you.

0 Kudos