Software Archive
Read-only legacy content
17061 Discussions

Installing Fortran and then C++ clobbers Visual Studio

chuckwh
Beginner
440 Views

This has happened to me twice in the past few months.  Earlier I was working (for years) with Fortran 2013 integrated in Visual Studio, and then I needed C++ for a project.  Since I own both (as part of the Cluster Studio) I installed C++ and told it I wanted it integrated with Visual Studio.  The net result was that my Fortran became unusable.  So I did my C++ project, and then had to do a clean re-install of the Fortran.

Since then I moved on to Visual Studio 2015, and I have been successfully using Fortran 2015 update 7 for a few months.  I needed to work on the C++ project, so today I tried to install C++ 2015 update 7.  The installation seemed to go fine.  Then I fired up Visual Studio and it told me that the IntelCpp integration package failed to load.  After several attempts with reboots and restarting of Visual Studio, I gave up and used the Control Panel to uninstall C++.  As it worked, one of the steps told me that it was uninstalling Fortran.  That is not what I asked it to do.  It seems that Composer is Composer to the uninstaller.

This is annoying.  Is it not possible to have both Fortran and C++ installed and usable under Visual Studio at the same time???  Is there some trick that nobody has told me?  Is there a certain order or something?

0 Kudos
2 Replies
Soflen_S_Intel
Employee
440 Views

Hi Charles,

I saw you have "IntelR Parallel Studio XE Cluster Edition for Windows* Version: 2017".
If you install this package (2678MB), C++ & Fortran compiler will be integrated to your VS at the same time. Uninstalling the package should remove these two compilers at the same time as well.

Best regards,
Soflen

0 Kudos
chuckwh
Beginner
440 Views

I have the whole Parallel Studio, but 95% of the time I use only Fortran and VTune, so I have been installing those packages individually, rather than use the all-in-one install.

So maybe installing Fortran and integrating into VS, and then later installing C++ and asking it to integrate into VS is not what is intended.  Sort of a "by design" issue.

I will move forward by uninstalling all Intel packages, and then install the whole Parallel Studio.  Probably what I am supposed to do is "customize" the install to get the tools I want.  Then later I could do a "modify" of the installation if I'd like to add more tools.

Thanks,
Chuck

0 Kudos
Reply