Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Irene_L_
Beginner
45 Views

Intel UP board cannot detect Intel's SR300 depth camera

Hello,

 

I have read other posts that have a problem just like mine (such as this one RealSense SR300 Depth Camera not found ) but none of them has a solution that works for me.

 

First I got the SR300 camera and I tested it with my laptop (running Win10), I connected the camera, installed the corresponding DCM, Intel's SDK and everything worked great. 

 

But now I am using the UP board that comes as part of the Intel® RealSense™ Robotic Development Kit with the same Windows 10 (fresh install with the board connected to the internet and no pending updates) and I am getting the error: "The installer failed to detect an Intel® RealSense™ 3D camera on this system" when I try to install Intel's DCM. These are screenshots of the errors I'm getting (excuse that it is in Spanish):

inteldcm.png

"The installer has failed to detect the Intel RealSense 3D camera in the system. The installation has been cancelled"

 

intelsdk.png

 

In both screenshots the camera was connected to the board's USB 3.0. I tried connecting it with two different cables (one that goes directly from the camera to the board's port and another one that needs to go through an adapted that comes with the board) but I got the exact same results.

 

Just like it happened with some of the other people that had a problem like this, the camera is actually recognized by the system.

 

This is my of the ejectable devices' list: 

 

plugged_devices.png

 

 

And this one the device manager:

 

device_manager.png

 

Under the ¨image devices¨ tab there are two devices, I verified and one corresponds to the RGB camera and the other one to the Depth camera. The camera's microphone is also detected (on the second red rectangle). When I run the "Camera" application on Windows I can view the RGB image taken by the camera, but not the depth image. I think this is to be expected since I can't install the DCM. The UP board only has one USB 3.0 port (and I have only one board) so I cannot change the camera to another USB, a solution that seemed to work for other people.

 

I don't think that the USB 3.0 port is faulty because the UP board has no trouble with the R200 camera that comes with the kit; I only have to install the DCM, the SDK and the R200 camera works on the UP just like the SR300 did on my laptop. To ensure that the problem wasn't caused by the R200 camera I formatted the board, reinstalled Windows from scratch and since then I have only connected the SR300 camera, but with the same results.

 

I believe that I should be able to use the SR300 with the UP board and I haven't found any indication to the contrary in the documentation, but I would like to confirm this. 

 

Thank you,

0 Kudos
2 Replies
Roi_Z_Intel
Employee
45 Views

try installing linux and than test the SR300

0 Kudos
Irene_L_
Beginner
45 Views

Roi Z. (Intel) wrote:

try installing linux and than test the SR300

 

Hello, sorry, but Linux would not work for me since the RealSense SDK, with the computer vision algorithms are vital to my project (they are the reason why I bought this camera instead of others) and they are only for the Windows SDK.  

 

Thank you. 

0 Kudos