Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
31 Views

Simulator

Some settings work while in DESIGN but same don't work on SIMULATOR.Like Galleria Image size property.

Tags (2)
0 Kudos
9 Replies
Highlighted
31 Views

Alex -- do they work properly on device?

0 Kudos
Highlighted
31 Views

Hi Alex,

Can you provide an specific example of code (maybe also screenshots) where you see this difference between design and the simulator. This will help us to understand and find a solution or provide you with a workaround to the problem. 

Thanks!

0 Kudos
Highlighted
Beginner
31 Views

I have used GALLERIA in fullscreen mode and provided height and width.It displays fine in DESIGN section but in simulator and device the galleria shrinks to smaller size.I had a lot of trouble in removing the fatal errors of setting galleria stage height and width and now I have to face such situation.This totally brings one down using Image gallery control.I have found some other bugs also in this XDK .

 

 

 

 

 

 

 

 

 

0 Kudos
Highlighted
Beginner
31 Views

Paul F. (Intel) wrote:

Alex -- do they work properly on device?

No the simulator display is mostly same as on real device.

0 Kudos
Highlighted
31 Views

I've asked our App Designer expert to take a closer look at what's going on.

0 Kudos
Highlighted
Employee
31 Views

It's hard to debug from screenshots.  Are you setting the dimensions in the image-gallery-size style?  If so, to what? Are you attempting anything else?  You said you use "fullscreen mode", but I'm not familiar with that mode. What do you mean by that?

I made a simple page with a galleria element and some text below it. I set the galleria element height (using the image-gallery-size style in App Designer) to be 80vh. That works well.  

Also note that Galleria doesn't stretch elements. So your image sources have to be big enough themselves. If they are only 100px x 100px, they'll never be terribly big.

 

0 Kudos
Highlighted
Beginner
31 Views

CHRIS P. (Intel) wrote:

It's hard to debug from screenshots.  Are you setting the dimensions in the image-gallery-size style?  If so, to what? Are you attempting anything else?  You said you use "fullscreen mode", but I'm not familiar with that mode. What do you mean by that?

I made a simple page with a galleria element and some text below it. I set the galleria element height (using the image-gallery-size style in App Designer) to be 80vh. That works well.  

Also note that Galleria doesn't stretch elements. So your image sources have to be big enough themselves. If they are only 100px x 100px, they'll never be terribly big.

 

Thanks CHRIS P.

  • I have given height of 300px; and width of 350px; I was trying to implement fullscreen mode of gallerio.io but nevermind,keep it aside.I was able to visualize the result in simulator,The images were covering the galleria stage .However in simulator,the result was not visible.It was still the same.
  • Besides,I wish to know that if images are kept in a different folder other than gallery_images,Is that wrong? Because I was getting Image not found error in build.The path of images was set properly.
    PAUL F. (Intel) wrote:
    This is the reason I was telling that the errors shall be already displayed in simulator.Mostly it does though but not in this case.

With great regards,

Alex.

 

 

0 Kudos
Highlighted
Employee
31 Views

You can keep the images wherever you want - even elsewhere on the internet, just so long as the JSON file has the right paths in it.

0 Kudos
Highlighted
Beginner
31 Views

I solved this by using a separate css for my changes to be updated.In old default css the changes were not saved,but now it does.

0 Kudos