Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Jacob_K_2
Beginner
70 Views

Speckle noise in color stream

Hi all,

I've got a zr300 camera, and I'm seeing a weird phenomenon where I'm getting green speckles  in the color images when there's something dark in an affected part of the field.  Here's an example where the entire field is dark.  You can see a diamond of speckles in the center, and scattered speckles out in the corners; averaging over many frames suggests a speckle distribution of that central diamond, followed by an annulus where there are no speckles, followed by more annuli that alternate speckles/ no speckles.    The speckles are most prominent in the green channel, are also present in the red channel (mostly at different pixels), but are absent in the blue channel. 

A co-worker who also has a zr300 reports similar behavior with his camera.   

2016-11-16.png

0 Kudos
2 Replies
JesusG_Intel
Moderator
70 Views

Hello Jacob, please confirm which RealSense camera you have by looking under Device Manager->Imaging Devices. Please send us a screenshot. Also, which application are you running and on which platform?

If you would like further assistance, please post your question in the RealSense Community. This forum in the Intel Developer Zone will soon be archived and all support will be handled in RealSense Community.

 

Regards,

Jesus Garcia

Intel Customer Support

Jacob_K_2
Beginner
70 Views

I'm using a ZR300, here's a screenshot from DeviceManager:

 

zr300.devicemanager.png

We've seen this behavior on a variety of applications and platforms, including the demo apps that come with the SDK.

I'll repost in RS Community.

Reply